Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Плиз подскажите что тут не так...Нужно написать программу в паскале АВС...Я ввожу это,а программа пишет ошибка ожидалось присваивание := Ничего не пойму...

5-9 класс

..
Задача такая:программа считает средний арифметический балл успеваемости ученика за четверть...например:математика 4,русский 5,информатика 5.......ничего не получяется

Belova86 19 авг. 2016 г., 17:36:34 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
щандрей
19 авг. 2016 г., 20:28:27 (7 лет назад)

Перегрузи комп!!!!!!

+ 0 -
Irinadrozdova2
19 авг. 2016 г., 21:21:10 (7 лет назад)

вы запускали через abc net? на какой строчке выдает ошибку?

+ 0 -
Krutoy2003
19 авг. 2016 г., 21:51:32 (7 лет назад)

var n,i:integer;
a:string;
sr:real;
begin
readln(a);
n:=0;
sr:=0;
for i:=1 to length(a) do
if a[i] in ['2'..'5'] then begin
sr:=sr+strtoint(a[i]);
n:=n+1;
end;
sr:=sr/n;
writeln(sr:2:1);
end.

так попробуйте

+ 0 -
сашамими
19 авг. 2016 г., 23:03:51 (7 лет назад)

нет,я открывала через АВС

+ 0 -
денис23w
20 авг. 2016 г., 1:44:22 (7 лет назад)

спасибо,все получилось!

Ответить

Другие вопросы из категории

Дан массив целых чисел. Найти:

а) сумму элементов массива, которые не превышают 20.
б)сумму нечетных элементов.

перевести числа из десятичной системы счисления в двоичную

135,197,203

из 2 ичной в 10 тичную перевести
11101;10101;11011

Читайте также

Артур всегда очень боялся знакомиться с девушками. Дело даже не в природной стеснительности Артура, и даже не столько в том, что Артур не знает, о чем

говорить с девушками. Просто Артур с детства не выговаривает букву «р» и очень этого стесняется. Поэтому Артур старается не произносить лишний раз слова, в которых есть эта ненавистная ему буква.Однажды друзья познакомили Артура с девушкой по имени Нина (о, какое прекрасное имя!). Она была очаровательна и очень болтлива, поэтому Артуру почти не нужно было подбирать слова — она заполняла неловкую тишину за него. Разумеется, он пригласил ее в кафе выпить чашечку кофе. Артур даже продумал все свои реплики заранее: «Счастлив тебя видеть», «Ты сегодня восхитительна», «Да, конечно, я внимательно тебя слушаю», «И что дальше?», «Счет, пожалуйста» и, конечно, «Я позвоню тебе на днях, не скучай».Но, как известно, не бывает идеальных планов. Все шло как по маслу, но вдруг, сидя за столиком в кафе, Нина сказала, что ужасно не выспалась и не отказалась бы от N чашек кофе. И тут Артур понял, что он не обдумал заранее, как он будет делать заказ. Понятно, что нужно сказать что-то вроде: «Сколько-то чашек кофе, пожалуйста», но вот сколько же чашек нужно, чтобы Нина так и не поняла, что Артур не выговаривает букву «р»? Явно нужно заказать не меньше, чем N + 1

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.

1.объём сообщения равен 11Кбайт.Сообщение содержит 11.264 символа. Ответ мощность алфавита с помощью которого было записано сообщение =256,нужно написать

решение задачи полностью.
2.Дан текст из 600 символов . Известно ,что символы берутся из таблицы размером16*32.Ответ информационный объём текста в битах =5.400бит.нужно написать решение задачи полностью.

Program tutor;

var
x: byte;
const
P = 12;
A = 6;
B = 10;
C =11;
begin
X:= (P*(P-A)*(P-B)*(P-C))^(1/2);
Writeln(x);
end.

Что в этой программе не так? Я хочу извлечь корень из х, а программа пишет "ОШИБОЧНЫЙ ИДЕНТИФИКАТОР".

Program tutor;
var
X, Z: byte;
const
P = 12;
A = 6;
B = 10;
C =11;
begin
X:= (P*(P-A)*(P-B)*(P-C))^(1/2);
Z:=sqrt(X);
Writeln(x,z);
end.

И через "sqrt"- оператор не хочет выдавать корень из Х. Что я не так делаю? подскажите.



Вы находитесь на странице вопроса "Плиз подскажите что тут не так...Нужно написать программу в паскале АВС...Я ввожу это,а программа пишет ошибка ожидалось присваивание := Ничего не пойму...", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.