Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу в паскале:1.Дано целое число. Вычислить, если возможно, натуральный логарифм этого числа и вывести его на экран. В противном

10-11 класс

случае вывести сообщение об ошибке.

Skunc 31 окт. 2016 г., 12:41:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Влад9мир
31 окт. 2016 г., 13:48:07 (7 лет назад)

Логарифм существует только для положительных чисел.
Поэтому напишем такую программу:

var  x:integer;
BEGIN
writeln('Введите число');
readln(x);
if  x<=0 then 
     writeln('Логарифм этого числа не существует')
     else write('ln=',ln(x))
END.

Ответить

Другие вопросы из категории

Читайте также

Помогите написать программу в Паскале и блок-сxему.

Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число отрицательное, то ничего с ним не делать. Вывести результат на экран.

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.



Вы находитесь на странице вопроса "написать программу в паскале:1.Дано целое число. Вычислить, если возможно, натуральный логарифм этого числа и вывести его на экран. В противном", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.