Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

5 произвольных чисел найти и вывести разницу между соседними числами информатика.

5-9 класс

(Через цикл repeat,until)

MrFocus 08 июня 2014 г., 10:46:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АлЕнКабб
08 июня 2014 г., 12:49:57 (9 лет назад)

const
  n = 5;

var
  m: array[1..n] of integer;
  i: integer;

begin
  Write('Введите через пробел пять целых чисел: ');
  i := 1;
  repeat
    Read(m[i]);
    i := i + 1
  until i > n;
  i := 2;
  repeat
    Writeln(m[i], '-', m[i - 1], '=', m[i] - m[i - 1]);
    i := i + 1
  until i > n
end.

Тестовое решение:

Введите через пробел пять целых чисел: 5 12 32 8 24
12-5=7
32-12=20
8-32=-24
24-8=16


Ответить

Другие вопросы из категории

Найдите лишнее слово и почему? Кто прочитал моё прошлое сообщение извините написала не правильно :(

Клавиатура,
джойстик, сканер, принтер.


Монитор,
графопостроитель, принтер, мышь.


Жесткий диск,
flash-память, компакт-диск, процессор.


Принтер,
акустические колонки, наушники, микрофон.


Системный блок,
центральный процессор, оперативная память, жесткий диск, блок питания.


Системный блок,
клавиатура, мышь, монитор, акустические колонки.


Видеокарта,
карта расширения, звуковая карта, сетевая карта.


Enter, End, Esc,
Delete.


Цветной принтер,
лазерный принтер, матричный принтер,
струйный принтер.

Помогите пожалуйста с информатикой!

Нужно составить программу для вычисления а в n-ой (энной) степени, где а, n - числа, введенные с клавиатуры. Желательно с постановкой задачи

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.
Формат выходных данных
Выведите ответ к задаче.



Вы находитесь на странице вопроса "5 произвольных чисел найти и вывести разницу между соседними числами информатика.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.