Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

составьте программу дискриминанта так, чтобы а,b,с -задавались генератором случайных чисел (random);+эта программа должна включать в себя

10-11 класс

!двухмерный массив размером 5 на 10 ( в Pascal )

Doq1111 24 июня 2014 г., 11:51:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chukalinm
24 июня 2014 г., 14:04:36 (9 лет назад)

var

a: array [1..5,1..10] of integer;
i,j:integer;
begin
for i:=1 to 3 do
begin
for j:=1 to 10 do

a[i,j]:=random(50)-100;
end;
for j:=1 to 10 do
a[4,j]:=sqr(a[2,j])-4*a[1,j]*a[3,j];
for j:=1 to 10 do
writeln('a=',a[1,j],' b=',a[2,j],' c=',a[3,j],' D=',a[4,j]);
readln;
end.

 p.s не понял зачем там массив 5х10 если нужно найти дискриминант?

Ответить

Читайте также

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел



Вы находитесь на странице вопроса "составьте программу дискриминанта так, чтобы а,b,с -задавались генератором случайных чисел (random);+эта программа должна включать в себя", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.