Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

10-11 класс

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Yakimovaele 26 янв. 2015 г., 17:07:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Juli1196
26 янв. 2015 г., 20:01:26 (9 лет назад)

программа рассчитана на то, что на экран выводится самый последний массив с результатами.

uses crt;
const
p=5;
r=5;
s=5;
var a:array[1..p] of integer;
b: array[1..r] of integer;
c: array[1..s] of integer;
m: array[1..3] of integer;
k,l,i,g,j,d,v,n:integer;
begin

readln(l);
  writeln;
 
for i:=1 to p do
readln(a[i]);
   writeln;
  
for j:=1 to r do
readln(b[j]);
     writeln;
    
for g:=1 to s do
readln(c[g]);
     writeln;
    
for i:=1 to p-1 do
repeat
d:=0;
if a[i]>a[i+1] then
begin
d:=1;
a[i]:=a[i]+a[i+1];
a[i+1]:=a[i]-a[i+1];
a[i]:=a[i]-a[i+1];
end;
until d=0;

for j:=1 to r-1 do
repeat
d:=0;
if b[j]>b[j+1] then
begin
d:=1;
b[j]:=b[j]+b[j+1];
b[j+1]:=b[j]-b[j+1];
b[j]:=b[j]-b[j+1];
end;
until d=0;

for g:=1 to s-1 do
repeat
d:=0;
if c[g]>c[g+1] then
begin
d:=1;
c[g]:=c[g]+c[g+1];
c[g+1]:=c[g]-c[g+1];
c[g]:=c[g]-c[g+1];
end;
until d=0;

for i:=1 to p do
if a[i]=l then inc(v);
m[1]:=v;
v:=0;

for j:=1 to r do
if b[j]=l then inc(v);
m[2]:=v;
v:=0;

for g:=1 to s do
if c[g]=l then inc(v);
m[3]:=v;

for n:=1 to 2 do
repeat
d:=0;
if m[n]>m[n+1] then
begin
d:=1;
m[n]:=m[n]+m[n+1];
m[n+1]:=m[n]-m[n+1];
m[n]:=m[n]-m[n+1];
end;
until d=0;

for n:=1 to 3 do
writeln(m[n]);
end.

Ответить

Другие вопросы из категории

для чего необходимы драйверы?
Паскаль

Помогите пожалуйста 10 класс . много чего ещё не понимаю
1) Определите сумму четных чисел до числа N введённые с клавиатуры
N=10
S=2+4+6+8+10=30
2) Составить программу которая вводит с клавиатуры число N и определяет произведение всех чисел
N=4
P=1*2*3*4=24
помогите пожалуйста

Читайте также

Написать программу на С++. Дана целочисленная квадратная матрица произвольной размерности. Сформировать одномерный массив, в который поместить элементы

двумерной матрицы, находящиеся над побочной диагонали; упорядочить их по возрастанию и найти их среднее арифметическое.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Одномерные массивы. 3 задачки))

1) Из элементов данного массива W[1..20] создать 2 новых массива, первый из которых содержит только положительные элементы, а второй только отрицательные.

2) Заполнить СЛУЧАЙНЫМИ числами в диапазоне от 1 до 10 два массива A[20] и B[20]. Найти и вывести на экран только те элементы этих массивов и их номера, значения которых попарно совпадают.
Например, если A[2]=B[2]=4, то на экран надо вывести: Номер-2, значение-4.
3) Заменить найденный минимальный элемент числом 100 и показать на экране массив с этой заменой.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.



Вы находитесь на странице вопроса "Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.