Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите написать код программы в Pascal для задачи:

10-11 класс

дано натуральное число n среди чисел 1,2 ... n найти все те, которые можно представить в виде суммы квадратов двух натуральных чисел.
Заранее огромное спасибо!!

LinKaz 13 окт. 2014 г., 14:34:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kissyla
13 окт. 2014 г., 17:16:04 (9 лет назад)

var
    n, i, j: integer;

begin
    read(n);
    for i := 1 to n - 1 do
        for j := i to n - 1 do
            if i * i + j * j <= n then
                writeln(i,'^2 + ',j,'^2 = ',i * i + j * j);
end.

Ответить

Читайте также

Помогите написать код программы в Pascal для задачи:

дано натуральное число n среди чисел 1,2 ... n найти все те, которые можно представить в виде суммы квадратов двух натуральных чисел.
Заранее огромное спасибо!!

Код программы "Тест" на Pascal

Необходимо написать код программы в формате .txt , чтобы на экране выводилось следующее:

1. Выводится текст "Вам предлагается тест на тему "Поведение в кабинете информатики""

2. Выводится вопрос и несколько вариантов ответа.

3. Выводится "Выберите № ответа".

4. Вопросов всего 3.

5. Выводится "Тест окончен".

6. Выводится "Оценка: Зачет" или "Оценка: Незачет"

Вот сами вопросы:
1. На каком расстоянии от монитора должен
работать ученик за компьютером?

a) 15-20 см

b) 50-70 см

c) Меньше 40 см
d) 90-110 см
2. Можно ли класть тетради, книги, диски на
монитор и клавиатуру?

a) Можно.

b) Можно только на клавиатуру.

c) Можно только на монитор.

d) Нельзя.
3. При появлении запаха гари нужно…

a) Бежать за водой, чтобы предотвратить
дальнейшее возгорание.

b) Прекратить работу, сообщить
преподавателю
c) Не обращать внимания
d) Быстро убежать из кабинета

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Написать код программы для решения следующей

задачи: Дано 5 чисел. Посчитать произведение максимального и минимального чисел для
данного подмножества. Результат вывести на экран. Язык программирования C++

Написать код программы для решения следующей

задачи: Дано 5 чисел. Посчитать произведение максимального и минимального чисел для
данного подмножества. Результат вывести на экран. Спасибо)



Вы находитесь на странице вопроса "Помогите написать код программы в Pascal для задачи:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.