Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

10-11 класс

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

Slonik555 22 сент. 2013 г., 13:20:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
S321
22 сент. 2013 г., 14:18:33 (10 лет назад)

1 задача.
var a,b,c:integer;
begin
clrscr;
readln(a,b,c);
if a>=b and a>=c then writeln(a) else
if b>=a and b >= c then writeln (b) else
writeln(c);
end.
2-я задача.
var a,s,i:integer;
begin
clrscr;
readln(a);
s:=0;
for i:=1 to a do
s := s+i;
writeln(s);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста! Составить блок-схему алгоритма решения задачи, условие которой выбирается из списка в соответствии с номером варианта. Оплата за

пользование электроэнергией производится по разным тарифам в зависимости от того, установлены ли в доме электрические или газовые плиты. В первом случае (электрические плиты) стоимость 1 кВт/час составляет 2 руб., во втором – 2.5 руб. Составить программу расчета суммы оплаты за пользование электроэнергией за месяц, если известен расход электроэнергии (количество потребленных в течение месяца кВт/час)

Читайте также

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Написать

программу, которая определяет среди заданных трех чисел равные числа



Вы находитесь на странице вопроса "1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.