Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В прошлых темах писали что это олимпиадные задания, но это не так. Эти задания учитель дал всему классу и сказал решить.

5-9 класс

1234lilu 19 нояб. 2013 г., 1:38:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Borisovaielien
19 нояб. 2013 г., 2:22:59 (10 лет назад)

var start_gen, gens, min_res,result:string;
i,j,t:integer;

Begin
  readln(start_gen);
  readln(gens);
 
  min_res := 'zzzz';
  for i := 1 to round(power(2,length(gens))) do begin
    t := i;
    result := trim(start_gen);
    for  j:= 1 to length(gens) do begin
      if t mod 2 = 0 then
        result :=  result + gens[j]
      else
        result :=  gens[j]+result;
      t:=t div 2; 
    end;
    if result < min_res then
      min_res:=result;
  end;

  writeln(min_res);
End.

Ответить

Другие вопросы из категории

Закончите определения: Информатика - это наука География - это наука Фонетика - это

раздел науки о

Ботаника - это раздел науки о

Имя существительное - это самостаятельная часть речи,

Глагол - это самостаятельная часть речи,

Земледельцы - это люди,

Животноводы - это люди,

Тяжёлая промышленность - это

Лёгкая промышленность - это

Заранее спасибо

Вознаграждение большое

Как вставить рисунок в MS World?

Читайте также

Привет у меня проблемы с компютером (буду писать ПК), и вот,мой ПК Не выключается, тоесть, после работы на ПК (игры, и прочее ) я хочу выключить ПК и вот

нажымаю я на "Завершение работы " и ничего не приисходит (ПК не выключается ) и я пытаюсь открыть после этого какой либо файл, например игру, видео, музыку ничего не вклбчается.. и чтобы выключить ПК нужно вытянють вилку с ризетки..
P.s Прошу пожалуйста помогите мне это решить :( что это может быть? Жду коректных ответов

1. Известно, что Саша старше Оли,но младше Пети. Вася старше Саши и Коли. Оля - не самая младшая, а Вася - не самый старший из ребят. Расположите имена

ребят по их возрасту в порядке возрастания.

2. В соревнованиях по плаванию участвовали Андрей, Виктор, Саша и Дима. Их друзья высказали предположения о возможных победителях:
1) первым будет Саша, Виктор будет вторым,
2) вторым будет Саша, Дима будет третьим,
3) Андрей будет вторым, Дима будет четвертым.
По окончании соревнований оказалось, что в каждом из предположений только одно из высказываний истинно, другое - ложно.
Какое место на соревнованиях занял каждый из юношей.

3. Виновник ночного дорожно-транспортного происшествия скрылся с места аварии.
Первый из опрошенных свидетелей сказал, что это были Жигули, первая цифра машины - единица.
Второй свидетель заявил сказал, что машина была Москвич, а номер начинался с семерки.
Третий свидетель заявил, что машина была иностранная, номер начинался не с единицы.
Оказалось, что каждый из свидетелей правильно указал либо марку, либо первую цифру номера. Какой машина была марки и с какой цифры начинался номер?

помогите пожайлуста))))))))))) Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из

моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.

ввод:1, 1, 1, 2, 2, 2

вывод: 3661

ввод:1,2,30,1,3,20

вывод: 50

это задача на pascal ABC

1. Русский царь петр | прорубил это в Европу это бывает на экране при работе компьютера и является основой в названии операционной

системы для персональных компьютеров. Что это?
2. С помощью этого коня ахейцы одержали победу над царем Приамом. Сегодня так называют один из самых известных компьютерных вирусов. О каком вирусе идет речь?
3. В одной многодетной семье у каждого из пяти сыновей было по три сестры. Сколько детей в этой семье?
4. Вписав недостающее пятое число, завершите ряд: 77, 49, 36, 18 ....

1. Как называется свойство алгоритма,1. Как называется свойство алгоритма, означающее, что данный алгоритм применим к решению целого класса задач?

а) понятность
б) определённость
в) результативность
г) массовость
2. Как называется свойство алгоритма, означающее, что он всегда приводит к результату через конечное, возможно, очень большое число шагов?
а) дискретность
б) понятность
в) результативность
г) массовость
3. Как называется свойство алгоритма, означающее, что он задан с помощью таких предписаний, которые исполнитель может воспринимать и по которым может выполнять требуемые действия?
а) дискретность
б) понятность
в) определённость
г) массовость
4. Как называется свойство алгоритма, означающее, что пусть решения задачи разделён на отдельные шаги?
а) дискретность
б) определённость
в) результативность
г) массовость
5. Как называется свойство алгоритма, означающее, что путь решения задачи определён вполне однозначно, на любом шаге не допускаются никакие двусмысленные и недомолвки?
а) дискретность
б) понятность
в) определённость
г) результативность



Вы находитесь на странице вопроса "В прошлых темах писали что это олимпиадные задания, но это не так. Эти задания учитель дал всему классу и сказал решить.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.