Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите очень нужно)

5-9 класс

Имеются переменые x,y,z для положительных чисел вывести удвоеное произведение для отрицательных в квадрат

Annafedorova2 18 дек. 2014 г., 6:49:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mariyaglushako
18 дек. 2014 г., 9:48:35 (9 лет назад)

Не совсем требования к программе понятны. Написал на ПаскальАВС.Нет с использованием функции

var x,y,z:integer;
function ex(x:integer):integer;
begin
if x>0 then result:=2*x
  else result:=x*x;
end;
begin
write('Введите x, y, z: ');
readln(x,y,z);
x:=ex(x);
y:=ex(y);
z:=ex(z);
writeln('Новые значения: ',x,'; ',y,'; ',z);
end.

Вариант без использования функции

+ 0 -
Mansursagaev199
18 дек. 2014 г., 10:48:02 (9 лет назад)

Т.е. даны три числа и если положительное то вывести удвоеное произведение ,если отрицательно то в квадрат?

+ 0 -
Jenya05
18 дек. 2014 г., 12:41:09 (9 лет назад)

да

+ 0 -
Ktoto499mailru
18 дек. 2014 г., 13:25:54 (9 лет назад)

Паскаль?

+ 0 -
Svetiklaskovec
18 дек. 2014 г., 13:56:41 (9 лет назад)

угу

Ответить

Другие вопросы из категории

Решите задачу по информатике!

Сообщение занимает 2 странице и содержит одну шестнадцатую Кб информации, на каждой странице записано 256 символов. Какова мощность использования алфавита?

Читайте также

помогите плиз очень нужно:превратите одно слово в другое всякий раз заменяя по одной букве так,чтобы новое слово было существительным в именительном падеже

.
а)ночь-?-?-?-?-?-день
б)рота-?-?-?-?-?-полк
в)бант-?-?-?-?-?-коса
г)бег-?-?-?-?-?-?-?-шаг
д)море-?-?-?-?-?-?-суша
е)миг-?-?-?-?-?-?-?-век
помогите очень нужно,учительница ужасно строгая ненавидит меня помогите!

Помогите эти задания зависят на оценку за четверть 1) Записать алгоритм распознания среди всех треугольников прямоугольные, если таковых нет

вычислить периметр.

2) Последовательно вводится N целых чисел найти кол-во равных нулю.

помогите очень нужно!

Помогите!Очень нужно)))

В строке символов определить кол-во букв А.
Нужно составить программу на Паскале))

ПОМОГИТЕ,ОЧЕНЬ НУЖНО! Проснувшись утром школьник почувствовал недомогание.Находившийся рядом злоумышленник составил для него следующий

алгоритм.

измерить температуру

если температура выше 37 С,то

вызвать врача

пойти в школу

Несмотря на недомогание,школьник исправил этот алгоритм,добавив всего 2 строки.какие строки добавил школьник?



Вы находитесь на странице вопроса "Помогите очень нужно)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.