Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Люди,прошу вас, помогите пожалуйста, я уже долго сижу над этой задачей,не могу решить,пожалуйста помогите! =(((

10-11 класс

найти номер третьего положительного элемента в потоке из 10 чисел или сообщить,что трех положительных элементов нет. (Решать без массива)

Yamaksi69 08 марта 2015 г., 19:14:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Semenov1982
08 марта 2015 г., 20:26:27 (9 лет назад)

Program Pr1;
uses crt;
var i,a,b,c:integer;
begin
clrscr;
b:=0;
for i:=1 to 10 do begin
readln(a);
if a>0 then b:=b+1;
if b=3 then begin
c:=a;
b:=11;
end;
end;
if b<3 then writeln('3 chisel >0 net')
else writeln(c);
end.

Обращайся ести что)))) 

Ответить

Другие вопросы из категории

Вопрос по информатике.
Нужна помощь!!!!!!!!!!!!!!!!!!
дан массив целых чисел (n=10), заполненный случайными числами из промежутка [-40,30]. 1. удалить из него все элементы, которые состоят из одинаковых

цифр(включая однозначные числа). 2. вставить число k перед всеми элементами, в которых есть цифра 1(k вводить с клавиатуры). 3. переставить первые три и последние три элемента местами, сохраняя их следование.

текстовый документ,состоящий из 5120 символов,хранится в 8-битной кадировке КОИ-8. этот документ был преобразован в 32-битную кодировку. укажите,какое

дополнительное количество Кбайт потребуется для хоанения документа . в ответе запишите только число

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

1)Сколько бит информации несет сообщение: "Пойманная в пруду рыба - щука", если всего в пруду 256 карасей, 40 щук, и 104 карпа?

2)В таксопарке 10 автомобилей "Волга", 7 автомобилей "Лада" и 8 автомобилей "Вольво". Сколько информации несет сообщение о марке автомобиля?

3)Была получена телеграмма: "Встречайте, вагон 7". Известно, что в составе поезда 16 вагонов. Какое количество Информации было получено

Ребята нужно с решением, прошу вас помогите бро.



Вы находитесь на странице вопроса "Люди,прошу вас, помогите пожалуйста, я уже долго сижу над этой задачей,не могу решить,пожалуйста помогите! =(((", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.