Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ПРОГРАММА НЕ ПРАВИЛЬНО РАБОТАЕТ. ГДЕ ОШИБКА?procedure par(msg:string);

10-11 класс

begin
write('Ошибка: ',msg);
halt(1);
end;
var
school,a:string;
begin
writeln('Введите пароль ');
read(a);
if a=school then write ('Вы получили доступ');
if a<>school then par('Доступ не был получен ');
end.

Лена144 19 янв. 2017 г., 15:53:52 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alborova
19 янв. 2017 г., 17:04:09 (7 лет назад)

От себя слова, которые идут на проверку, либо это русские, либо английские ставь в апострофы, это не числа. 
Ответ в файле

Ответить

Другие вопросы из категории

Исполнитель Черепашка ползет по клеткам бесконечной вертикальной клетчатой доски, переходя по одной из команд: вверх, вниз, вправо, влево - в соседнюю

клетку в указанном направлении. Черепашка выполнила следующую программу вниз влево вверх вправо вверх влево влево вправо вниз и перешла из клетки a в клетку b. Укажите наименьшее возможное число команд в программе, переводящей Черепашку из начальной клетки a в клетку b. 1) 1; 2) 2; 3) 3; 4) 4.

Написать программу для:

1. определите есть ли в данном массиве отрицательные элементы
2.

в паскале решите задачу :) 1. В строке слова разделены пробелами. Определить на какую букву оканчивается четвертое

слово в предложении.

2.Дана последовательность слов. Напечатать те слова последовательности, которые отличны от первого слова и удовлетворяют следующему свойству: в слове нет повторяющихся букв.

Напишите простейшую задачку в Pascal (алгоритмы ветвления if then):

Ввести возраст человека (от 1 до 150 лет) и вывести его вместе с последующим словом "год", "года", "лет".
--------------------------
Например, я вводу "150" и вместе с числом выходит "лет"
или я ввожу "21" и вместе с числом выходит "год"

Читайте также

помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"

const
N=20;
var
a:array [1..N] of integer;
i,j,max:integer;
begin
for i:= 1 to N do
readln(a[i]);
max:=99;
j:=a[i];
for i:= 1 to N do
if (j>99) and (j<999) and (j mod 9 <>0) and (j>max) then max:=j;
if max>99 then writeln (max) else writeln ('no');
readln;
end.

программа проверяет только последнее число, а не все 20. где ошибка?

Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколь

ко нулей. Разработать для программы не менее двух тестов и доказать правильность её работы.

Помогите, пожалуйста, решить задачу в Паскале (программа выводит не правильный результат, а понять где допущены ошибки не могу).

Задать массив из 30 положительных элементов случайным образом.
• найти кол-во нечётных элементов всего массива;
• найти минимальный элемент;
• элементы, кратные 10, заменить единицами и вывести новый массив.

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Здравствуйте! Помогите решить задания! Не понимаю программу Кумир, к сожалению, завтра последняя возможность исправить оценку. заранее

спасибо

1. Напечатать числовой ряд: 1,7,13,19,25,31,……….61 с помощью цикла «пока».

2. Написать программу, которая запрашивает число с клавиатуры и сообщает его квадрат, затем спрашивает пользователя «Нужно продолжить работу?», и пользователь отвечаетда/нет. Программа заканчивает свою работу, если пользователь напечатал слово «нет» на очередной вопрос программы, иначе считает и выдаёт ответ дальше.

3. Дан массив из 10-ти чётных натуральных чисел – от 2 до 20.

А) Найдите сумму элементов массива.

Б) Найдите минимальный элемент массива.

4. Дан массив из 15 подряд идущих натуральных чисел, начиная с 50.

А) Найдите произведение элементов массива.

Б) Найдите максимальный элемент массива.



Вы находитесь на странице вопроса "ПРОГРАММА НЕ ПРАВИЛЬНО РАБОТАЕТ. ГДЕ ОШИБКА?procedure par(msg:string);", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.