Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Определить, попадает ли точка с

5-9 класс

заданными координатами в полукруг радиусом R, расположенный в I и IV
четверти. (Уравнение окружности R2=x2+y2.). Помогите пожалуйста на С++ программу написать.

Машунька775 20 июля 2013 г., 17:01:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cmc2013m
20 июля 2013 г., 17:56:56 (10 лет назад)

Условие попадания точки в полукруг можно записать в виде
\begin {cases} x \geq 0 \\ x^2+y^2 \leq R^2 \end {cases}

#include <iostream>

using namespace std;

int main(){
    float x,y,R;
    cout<<"Vvedite a,b,R\n";
    cin>>x>>y>>R;
    if (x>=0 && x*x+y*y<=R*R)
        cout<<"\nPopadaet\n";
    else
        cout<<"\nNe popadaet\n";
}

Тестовое решение:
Vvedite a,b,R
3
5
7

Popadaet

--------------------------------
Process exited after 15.45 seconds with return value 0
Для продолжения нажмите любую клавишу . . .

Vvedite a,b,R
4
-2
3

Ne popadaet

--------------------------------
Process exited after 27.79 seconds with return value 0
Для продолжения нажмите любую клавишу . . .




Ответить

Читайте также

нужно составить блок-схему по инф.

задача: определить попадает ли точка М с координатами х,у в круг радиусом r с центром в начале координат.

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Пожаалуйста) В программе Geany Задача 1. Определить четность/нечетность числа, введённого пользователем (использовать операцию mod,

p>которая находит остаток от деления).

Задача 2.

Определить, попадает ли введенное число x в интервал [a, b], где числа a и b тоже задаются
пользователем.



Вы находитесь на странице вопроса "Определить, попадает ли точка с", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.