Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите написать программу в pascal.Дан набор слов, разделенных точкой с запятой (;). Набор заканчивается двоеточием (:). Определить, сколько в нем

10-11 класс

слов, заканчивающихся буквой а.

Zabava5 21 марта 2017 г., 12:49:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
шадрова
21 марта 2017 г., 14:21:50 (7 лет назад)

var
  str: string;
  i  : byte;

begin
  readln(str);
  str := str.Replace(':', '');
  foreach c: string in str.Split(';') do
    if (c[c.Length] in ['a', 'а']) then //не уточнено, какого алфавита "а"
      i += 1;
  writeln(i);
end.

+ 0 -
Lubimayy
21 марта 2017 г., 15:10:55 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Ребята, подскажите!Мне нужно в экселе сделать выборку,но я не могу найти её.В учебнике написанно в меню сервис выберем анализ данных и в открывшемя

окне инструмены анали выделим опцию выборка-затем ок.Но я немогу найти в 7 excel меню сервис(где его искать подскажите),но в 3 excel я нашла сервис но не могу найтианализ данных?!Подскажите.

ПОМОГИТЕ РЕШИТЬ СРОЧНО
1. Дан массив. Напечатать:а) Все четные1. Дан массив. Напечатать:

а) Все четные элементы
б) Все элементы, оканчивающиеся нулем.

2. В массиве хранится информация о количестве осадков, выпавших каждый день января. Определить, в какие числа месяца осадков не было.

В паскале. Заранее спасибо.

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL! ПОЖАЛУЙСТА!

Дан массив X(N,M). Если первый элемент массива положительный, то найти сумму элементов среди элементов четных строк массива, иначе произведение.

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу в pascal


Вы находитесь на странице вопроса "Помогите написать программу в pascal.Дан набор слов, разделенных точкой с запятой (;). Набор заканчивается двоеточием (:). Определить, сколько в нем", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.