Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Информатика, 8 класс. 4 задание, пожалуйста! Вопрос жизни и смерти! Если можете, то сделайте, пожалуйста скрин в паскале того, как у Вас получилось!

5-9 класс

JuliaLoll 10 нояб. 2013 г., 13:22:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ShValeriya
10 нояб. 2013 г., 16:07:14 (10 лет назад)

var
  n, m, n1, kc: integer;

begin
  Write('Введите целое трехзначное число: ');
  Readln(n);
  n1 := abs(n); {Вдруг кто-то отрицательное число введет!}
  if (n1 < 100) or (n1 > 999) then
    Writeln('Сам себе злобный буратино...')
  else begin
    kc := 0;
    repeat
      m := n1 mod 10;
      n1 := n1 div 10;
      kc := kc + m
    until n1 = 0;
    Write('Сумма цифр числа ', n);
    if (kc mod 2 = 0) then Writeln(' - четное число')
    else Writeln(' - нечетное число')
  end
end.

Тестовое решение:

Введите целое трехзначное число: 122
Сумма цифр числа 122 - нечетное число

Введите целое трехзначное число: 729
Сумма цифр числа 729 - четное число

Введите целое трехзначное число: -417
Сумма цифр числа -417 - четное число

Введите целое трехзначное число: 1320
Сам себе злобный буратино...






Ответить

Другие вопросы из категории

Дано трёхзначное число. Напишите программу, которая определяет:

а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;
пример входных данных: 123; 121; 222
пример выходных данных: нет; да; да
б) является ли число "перевёртышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

ПОЖАЛУЙСТА!!! В классе 1010 мальчиков, что составляет 101000% от численности всего класса. Сколько в классе девочек и какова общая численность

класса? Ответы получите в двоичной системе, в которой записаны все приведенные значения.

Помогите пожаааалуйста ;-( ;-(

1) Приведите пример циклического алгоритма:а) из литературного произведенияб)из любой предметной области изучаемой в школе.
2) Ежегодный прирост рыбы в пруду составляет 15%. Запасы рыбы оценены в А тонн. Ежегодный план отлова В тонн. Наименьший запас рыбы составляет С тонн (запас ниже С тонн уже не восстанавливается) .Составьте БЛОК СХЕМУ алгоритма для подсчета кол-ва лет, в течение которых можно выдерживать заданный план.

Что если шрифт с Times New Roman не меняется на Vivaldi? В чём дело?

P.S. всё это в программе Microsoft Office Word.

Читайте также

Помогите пожалуйста.Вопрос жизни и смерти, информатика помогите или хотя бы подскажите как делать.

Нужно сделать небольшой реферат на тему " Устройство компьютера". (процессор, устройства, ввод-вывод; что то вроде этого)

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Задание #1 Вопрос: Интернет - это: Выберите один из 4 вариантов ответа: 1) группа ПК, размещенных в одном помещении 2) глобальная компьютерная сеть,

объединяющая многие локальные, региональные и корпоративные сети 3) комплекс терминалов, подключенных каналами связи к ЭВМ 4) мультимедийный компьютер с принтером, модемом, факсом Задание #2 Вопрос: Файл - это: Выберите один из 4 вариантов ответа: 1) единица измерения информации 2) программа в оперативной памяти 3) область памяти ПК, имеющая имя 4) текст, напечатанный на принтере Задание #3 Вопрос: Укажите расширение файла proba.docx Выберите один из 4 вариантов ответа: 1) нет расширения 2) proba 3) docx 4) .docx Задание #4 Вопрос: Укажите тип файла fakt.exe Выберите один из 4 вариантов ответа: 1) текстовый 2) графический 3) исполняемый 4) Web-страница Задание #5 Вопрос: Скорость передачи данных через ADSL-соединение равна 256 000 бит/с. Передача файла через данное соединение заняла 3 мин. Определите размер файла в килобайтах. Выберите один из 4 вариантов ответа: 1) 125 2) 56 250 3) 45 000 4) 5 625 Задание #6 Вопрос: Для каких целей необходимо системное ПО Выберите один из 4 вариантов ответа: 1) для разработки прикладного ПО 2) для решения задач из проблемных областей 3) для управления ресурсами ЭВМ 4) для расширения возможностей операционной системы Задание #7 Вопрос: Локальная сеть объединяет: Выберите один из 4 вариантов ответа: 1) компьютеры одного учреждения 2) компьютеры нескольких учреждений 3) компьютеры одного региона 4) компьютеры, имеющие общие доменные имена Задание #8 Вопрос: Установите соответствие Укажите соответствие для всех 6 вариантов ответа: 1) информация, записанная на диск под определенным именем 2) программа, облегчающая работу пользователям с файлами и каталогами в операционной системе Windows 3) программы, используемые для работы на компьютере 4) первоначальная подготовка диска к работе - нанесение магнитных дорожек и секторов на его поверхность 5) программы, обеспечивающие работу компьютера и всех его устройств как единой системы 6) место на диске под определенным именем, где хранятся списки файлов и подкаталогов (папок) по определенной тематике __ программное обеспечение (ПО) __ форматирование диска __ операционная система __ файл __ каталог (папка) __ проводник Задание #9 Вопрос: URL- адрес Web-страницы http://www.mipcro.ru/index.htm. Укажите доменное имя компьютера. Выберите один из 4 вариантов ответа: 1) mipcro.ru 2) http 3) htm 4) index.htm Задание #10 Вопрос: Браузеры - это: Выберите один из 4 вариантов ответа: 1) серверы Интернета 2) антивирусные программы 3) трансляторы языка программирования 4) средства просмотра Web-страниц Задание #11 Вопрос: Что из перечисленного относится к браузерам Выберите несколько из 5 вариантов ответа: 1) Opera 2) Google 3) Excel 4) Mozilla 5) Hyper Text Задание #12 Вопрос: Тэг - это: Выберите один из 3 вариантов ответа: 1) инструкция браузеру, указывающая способ отображения текста 2) текст, в котором используются специальные символы 3) указатель на другой файл или объект Задание #13 Вопрос: Укажите теги, определяющие видимую часть документа Выберите несколько из 8 вариантов ответа: 1)2)3)

4)

5) 6)7)

8)

Задание #14 Вопрос: Укажите теги, определяющие размер заголовка Выберите несколько из 8 вариантов ответа: 1)2)3)

4)

5) 6)7)

8)

Задание #15 Вопрос: Запишите тэг, определяющий перенос на новую строку. Запишите ответ: __________________________________________ Конец



Вы находитесь на странице вопроса "Информатика, 8 класс. 4 задание, пожалуйста! Вопрос жизни и смерти! Если можете, то сделайте, пожалуйста скрин в паскале того, как у Вас получилось!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.