Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача на Паскале. (Действие с целыми переменными).

10-11 класс

Дано целое 3-х значное число, в нем крайнюю правую цифру зачеркнули и приписали е слева. Составить программу, реализующую это действие

пожаалуйста

Арпичка 16 окт. 2014 г., 23:17:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marinka197905
17 окт. 2014 г., 1:51:14 (9 лет назад)

Program ff;
  Var A,B,C : Integer; 
 Begin
  Writeln ('Введите трехзначное число');
   Read (A);
    B:= A Mod 10;
     C:= A Div 10;
     Write (B);
      Writeln (C);
  End.

Ответить

Читайте также

1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает

разность чисел p и q.
2.Что будет на экране после выполнения следующих команд: а) Writeln(9); Write(5); Writeln(3); б) Writeln(4*2); Write('5-3'); Writeln('5+1=',5+1);
3.Укажите различия циклов While и Repeat
4.Дана строка. Определить сколько пробелов в этой строке
6.Дано четырехзначное число. Вывести на экран сумму цифр этого числа
7.Найти количество цифр целого числа N
8.Напишите команды, которые выполняют следующие действия: а) ввод переменной d б) описать переменные m и n вещественного типа. в) переменной s присвоить разность чисел p и q
9.Что будет на экране после выполнения следующих команд: Writeln(5-3); Write('5+3'); Writeln('5*4=',5*4);
10.Когда нельзя применять цикл for
11.Дана строка. Определить сколько букв в этой строке
12.Дано трехзначное число. Вывести на экран все его цифры столбиком
13. Найти количество цифр целого числа N(+блок-схема)

Помогите написать задачу на паскале

================================================================
В одной берляндской школе появился новый ученик Вася, который очень сильно любил химию. К сожалению для учителя химии, Вася принебрегал техникой безопасности и любил смешивать все реагенты подряд. В кабинете химии находится n реагентов. Каждый реагент характеризуется целым числом - своей опасностью. При смешивании реагентов действовали такиме правилами:

смешивать можно только 2 реагента;
при смешивании реагентов, старые реагенты исчезали и появлялся новый реагент, опасность которого равнялась среднему арифметическому старых.

Известно, что Вася собирается смешивать реагенты до тех пор, пока не останется 1 реагент. Помогите учителю химии определить максимально возможную опасность окончательного реагента.

Здравствуйте) помогите составить задачи по паскалю)

задачи на такую тему: Составление, ввод, трансляция и
исполнение программ, реализующих
циклические алгоритмы и типовые
операции с одномерными массивами

Решить 2 задачи на Паскаль

1)Вычислить значения функции y=(x-1)^3 при изменении x на отрезке -5;5 с шагом 0,2 отпечатать каждое третье отрицательное значение и получить произведение положительных.
2)Найти сумму ряда y=x-(x^2)/2+(x^3)/3-...+((-1)x^n)/n
Плиз срочно надо



Вы находитесь на странице вопроса "Задача на Паскале. (Действие с целыми переменными).", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.