Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Вводятся 4 числа. Известно, что одно из них отлично от трѐх других. Нужно вывести это число. При любых входных данных алгоритм должен выполнять не более

10-11 класс

двух операций сравнения.

Taga21 04 марта 2015 г., 5:38:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Seli093
04 марта 2015 г., 7:18:22 (9 лет назад)

program gt;
label 1;
var a,b,c,d:integer;
begin
read(a,b,c,d);
if(a=b)then begin
if(a=c)then writeln(d) else writeln(c);
goto 1;
end;
if (a=c) then writeln(b) else writeln(a);
1:
end.

+ 0 -
Nata1223
04 марта 2015 г., 8:34:04 (9 лет назад)

жалко

+ 0 -
DRONCHIENKO0111
04 марта 2015 г., 10:15:24 (9 лет назад)

в общем ипользоват два сравнения или при проверке проверяет 2 раза(но с тремя if-ами)?

+ 0 -
Lampadova
04 марта 2015 г., 11:18:03 (9 лет назад)

у меня при любых данный проверяет 2 раза но у меня 3 if-а (написать?)

+ 0 -
Azametr
04 марта 2015 г., 13:00:52 (9 лет назад)

если можно

+ 0 -
лукапп
04 марта 2015 г., 15:52:38 (9 лет назад)

там при прохождении программы используется 2 ифа один отбразывается с помощью перехода или первым ифом

Ответить

Другие вопросы из категории

Рассмотрим алгоритм, преобразующий одно целое число в другое.

A. Умножить текущее число на 2.
B. Прибавить к результату 1.
C. Если получившееся число больше или равно 17, вычесть из него 17.
Какое получится число, если повторить этот алгоритм 7 раз для исходного
числа 4?
1) 9
2) 10
3) 13
4) 4

1. Составить программу нахождения суммы чисел 5, 10, 15, 20, …50.

2. Найти значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.

Читайте также

Петя, Вася и Маша остались дома одни. Кто-то из них ел варенье. На вопрос мамы, кто это сделал, они сказали:

а) Петя: "Я не ел. Маша тоже не ела."
б) Вася: "Маша действительно не ела. Это сделал Петя"
в) Маша: "Вася врет. Это он съел."

Выясните, кто ел варенье, если известно, что двое из них оба раза сказали правду, а третий один раз соврал, а один раз сказал правду.(Если можно, то с помощью лог. формулы или таблицы, пожалуйста)

На одной улице стоят в ряд 4 дома, в которых живут 4 человека: Алексей, Егор, Виктор и Михаил. Известно, что каждый из них владеет ровно одной из

следующих профессий: Токарь, Столяр, Хирург и Окулист, но неизвестно, кто какой и неизвестно, кто в каком доме живет. Однако, известно, что:

1) Столяр живет правее Хирурга

2) Окулист живет левее Хирурга

3) Токарь живет с краю

4) Токарь живет рядом с Окулистом

5) Егор не Токарь и не живет рядом с Токарем

6) Михаил живет рядом с Хирургом

7) Алексей живет правее Окулиста

8) Алексей живет через дом от Михаила

Выясните, кто какой профессии, и кто где живет, и дайте ответ в виде заглавных букв имени людей, в порядке слева направо. Например, если бы в домах жили (слева направо) Константин, Николай, Роман и Олег, ответ был бы: КНРО

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

1. На одной улице стоят в ряд 4 дома, в которых живут 4

человека: Андрей, Евгений, Василий и Михаил. Известно, что каждый из них
владеет ровно одной из следующих профессий: Банкир, Учёный, Хирург и Окулист,
но неизвестно, кто какой и неизвестно, кто в каком доме живёт. Однако,
известно, что:

На одной улице стоят в ряд 4 дома, в которых живут 4

человека: Семён, Николай, Артур и Роман. Известно, что каждый из них владеет
ровно одной из следующих профессий: Врач, Художник, Егерь и Тренер, но
неизвестно, кто какой, и неизвестно, кто в каком доме живёт. Однако известно,
что:

1)



Вы находитесь на странице вопроса "Вводятся 4 числа. Известно, что одно из них отлично от трѐх других. Нужно вывести это число. При любых входных данных алгоритм должен выполнять не более", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.