Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

каждый солнечный день улитка сидящая на дереве поднимается вверх на 2 см а в пасмурный день опускается на 10 см. в начале недели улитка находилась на а см

10-11 класс

от земли и на в метровом дереве. Имеются 30 массив, содержащий сведения о том был ли соответствующий день пасмурным. Определить место положения улитки к концу 30 дня. паскаль

Andrianadan1228 26 апр. 2015 г., 13:28:40 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jhenechka2000
26 апр. 2015 г., 15:03:25 (8 лет назад)

var day: array[1..30] of boolean;
i, pos, tree_height : integer;
Begin
  readln(pos, tree_height);

  for i := 1 to 30 do
    day[i] := (random(100) > 30);

  for i := 1 to 30 do begin
    if day[i] then pos := pos + 2
    else pos := pos - 10;

    if pos > tree_height then pos := tree_height;
    if pos < 0 then pos := 0;

    writeln('День ', i:2, '(', day[i]:5,') pos = ',pos);
  end;

  writeln(pos);
End.


+ 0 -
Ernest007
26 апр. 2015 г., 16:44:28 (8 лет назад)

Program Ulitka;
Var SunnyDay: Array [1..30] Of Boolean;
a, b, c, i: Integer;
Begin
WriteLn('a = ');
ReadLn(a);
WriteLn('b = ');
ReadLn(b);
b := b * 100;
Randomize;
For i := 1 To 30 Do
Begin      
If Random(2) = 1 Then
SunnyDay[i] := True
Else
SunnyDay[i] := False;
End;
For i := 1 To 30 Do
Begin  
If SunnyDay[i] = True
ThenBegin    
a := a + 2;    
If a > b Then    
a := b;  
End  
Else  
Begin   
a := a - 10;    
If a < 0 Then    
a := 0;  End;  
End; WriteLn('Дни месяца были таковы:');
For i := 1 To 30 Do
Begin
If SunnyDay[i] = True Then
WriteLn(i, '. Солнечный')
Else
WriteLn(i, '. Пасмурный')
End;
WriteLn('К концу 30 дня местоположение улитки равно ', a, ' см над землей');
End.

+ 0 -
пупся1342
26 апр. 2015 г., 19:36:05 (8 лет назад)

???

Ответить

Другие вопросы из категории

Упростите логические формулы

Читайте также

1Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см, а каждый пасмурный день опускается вниз на 1 см, В начале наблюдения

улитка находится в A см от земли на B-метровом дереве. Имеется 30-элементный массив, содержащий сведения о том, был ли соответствующий день наблюдения пасмурным или солнечным. Написать программу, определяющую местоположение улитки к концу 30-го дня наблюдения.
2.

каждый солнечный день улитка сидящая на дереве поднимается на 2см а в каждый пасмурный день опускается на 1см . в начале ноября улитка находилась ы А см

от земли на В дереве .имеется 30 элем.массив содержащим сведенья о том был ли соответствующий деньпасмурным или солнечным . написать программу определяющее место положения улитки к концу 30 дня наблюдения

Пользователь работал с каталогом с:\компьютер\Память. сначало он спустился в каталог ВИНЧЕСТЕР после этого поднялся на один уревень вверх затем еще раз под

нялся на один уровень вверх и даллее спустился в каталог ПРОЦЕССОРЫ укажите полный ответ который оказался пользователь
1-с:\компьютеры\Память\винчестеры
2-с:\компьютеры\Память\процессор ы
3-с:\винчестеры\процессоры
3-с:\компьютеры\процессоры

Улитка ползёт по вертикальному шесту высотой h метров, поднимаясь за день на a метров, а за ночь спускаясь на b метров. На какой день улитка доползёт

до вершины шеста? Программа получает на вход натуральные числа h, a, b и должна вывести одно натуральное число. Гарантируется, что a>b. При решении этой задачи нельзя пользоваться условной инструкцией if и циклами. Примеры Входные данные 10 3 2 Выходные данные 8

Спортсмен, начав тренировки, в первый день пробежал 10 км. Каждый следующий день он увеличивал дистанцию на 12 %. Написать программу, определяющую общую

длину пробега за месяц и первый день с начала тренировок, после которого дистанция превысит 25 км.
паскаль!!!



Вы находитесь на странице вопроса "каждый солнечный день улитка сидящая на дереве поднимается вверх на 2 см а в пасмурный день опускается на 10 см. в начале недели улитка находилась на а см", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.