Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу, которая для трех

1-4 класс

случайных чисел выводит на экран ответ на следующий вопрос: правда ли, что
первое число равно сумме второго и третьего.

Ответ должен быть выведен в виде <выражение>-<логическая
константа>

Rad20021 27 сент. 2016 г., 7:11:38 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kristinafjdj
27 сент. 2016 г., 10:00:00 (7 лет назад)

var i,d:integer;
n:array[1..3] of integer;
begin
writeln('Введите диапазон( от 0 до ...)');
readln(d);
randomize;
for i:= 1 to 3 do
beginn[i]:=random(d+1); 
writeln(n[i]);
end;
if n[1]= n[2]+n[3] then
writeln('YES')
else
writeln('NO');
end.

+ 0 -
Iraobuxova70
27 сент. 2016 г., 12:27:02 (7 лет назад)

а диапазон какой?

+ 0 -
Brink778
27 сент. 2016 г., 15:10:26 (7 лет назад)

я скинула все содержание задачи)

+ 0 -
Wdus
27 сент. 2016 г., 17:27:19 (7 лет назад)

ну раз не знаешь диапазон, то только так ))

+ 0 -
БигБон
27 сент. 2016 г., 20:19:38 (7 лет назад)

спасибо большое;)

+ 0 -
артёмыч11
27 сент. 2016 г., 21:55:48 (7 лет назад)

агась :ь

Ответить

Читайте также

Напишите программу, которая

позволяет ввести три вещественных числа и выводит на экран:


сумму
всех трех чисел;
модуль
разности первого и второго чисел;
целую
часть произведения второго и третьего чисел.


Все вещественные числа должны быть
выведены в форме с фиксированной точкой с двумя знаками после запятой; перед
каждым вычисленным значением должны идти пояснительный текст и выражение.

PascalABC 1. Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в

интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a ,

b ) .

Входные данные
Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b .

Выходные данные
Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.



Вы находитесь на странице вопроса "Напишите программу, которая для трех", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.