Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Написать алгоритм, определяющий, на какую цифру оканчивается заданное натуральное число. Записать решение в виде линейного алгоритма в Pascal ABC.

10-11 класс

Заранее спасибо)))

Sana99umnik 13 июля 2013 г., 6:42:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Маюша555
13 июля 2013 г., 8:30:22 (10 лет назад)

var i: integer;
begin
   readln(i);
   writeln(i mod 10);
end.

Так:)

Ответить

Другие вопросы из категории

помогите пожалуйста решить задачи

1. сообщение, записанное буквами из 64 символьного алфавита, содержит 20 символов. какой объем информации она несет?
2. сколько символов содержит сообщение, записанное с помощью 16 символьного алфавита, если его объем составил одну шестнадцатую часть мб?
3. сколько бит информации содержится в сообщении, размером 8 байт?

1920 бит перевести в Мбайты
ПОМОГИТЕ!!!!!!!!!!!

дана матрица В(6,6) (элементы выбрать самостоятельно) выяснить верно ли что наибольшее из значений элементов главной диагонали больше чем наименьшее из значений побочной диагонали. дать текстовое сообщение и напечатать для сравнения оба значения.
НАПИСАТЬ ПРОГРАММУ В VBA EXCEL

Вам необходимо по данным трём шаблонам (маскам)

правильно выбрать имя файла, которое подходит для всех трёх шаблонов
1. ?*sk*?.*j*??

2. *os?*a2.*p?

3. m?*kv*?.*??g

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Помоги срочно надо!!! С написанным на доске числом производят следующее действие. Каждую его цифру возводят в квадрат, все результаты суммируют и

результат выписывают на доску вместо исходного числа. Так продолжается сколько угодно раз. Опишите алгоритм, определяющий, можно ли таким образом получить из начального натурального числа N заданное натуральное число M? Обоснуйте конечность разработанного алгоритма.

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.



Вы находитесь на странице вопроса "Написать алгоритм, определяющий, на какую цифру оканчивается заданное натуральное число. Записать решение в виде линейного алгоритма в Pascal ABC.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.