Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите!!! 24 БАЛЛА!!! Если бы имел больше, то больше бы поставил за это решение!!!

5-9 класс

Надо сменить в языке Паскаль с While на Repeat !!!

Program P1;
Var a,n:integer;
Begin
Write ('a='); readln(a);
While a<>0 do begin
n:=n+1; a:=a div 10;
End;
Writeln('n=',n); readln
end.

Он сейчас в While, надо сменить этого в Repeat. Помогите ребята!!! Заранее благодарен!!!

Jemma2 16 окт. 2015 г., 22:29:14 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
наталя2310
17 окт. 2015 г., 1:14:55 (8 лет назад)

Program P1;
Var a,n:integer;
Begin
Write ('a='); readln(a);
repeat
n:=n+1; a:=a div 10;
until a=0;
Writeln('n=',n); readln
end.

Ответить

Другие вопросы из категории

Записать на Паскале задачу

даны два числа х, у большее из них возвести в квадрат.

СРОЧНО!!!!! сделать презентацию( не менее 6 слайдов) в powerpoint 2007 про Римму Мануковскую ( информация о ней: http://culturavrn.ru/person/8827

,http://www.kino-teatr.ru/kino/acter/w/sov/12612/bio) сделайте до завтра умоляю

даю 30 баллов. Наибольшим общим делителем (НОД) для двух целых чисел m и n называется наибольший из их общих делителей. Например, для чисел 70 и 105

наибольший общий делитель равен 35.


Вам заданы целые неотрицательные a и b (0 ≤ a,b ≤ 109). Напишите программу, которая выведет количество вычитаний при работе такого алгоритма и результат его работы.


Входные данные
Единственная строка входных данных содержит записанные через пробел целые числа a, b (0 ≤ a,b ≤ 109).


Выходные данные
Выведите количество вычитаний в ходе работы алгоритма и его результат через пробел.

вот мое решение но я не набираю все баллы значит ошибка есть помогите исправить

var
a,b,k:longint;
begin
read(a,b);
k:=1; // или (k:=0;)
if (a=0) and (b=0) then k:=0 else
while a<>b do begin if a>b then a:=a-b else b:=b-a ;inc(k); end; writeln(k);writeln(a);

end.

Читайте также

Митя,Серёжа,Толя,Юра и Костя пришли в музей до открытия и встали в очередь .Если бы Митя встал посередине очереди,то он стоял бы между Серёжей и Костей

,причём Костя стоял бы впереди Мити,а если бы Митя встал в конце очереди,то рядом с ним стоял бы Юра.Но Митя встал впереди своих товарищей .Кто за кем стоит?*

Помогите решить пожалуйста, если можно то блок-схемой:) Одна тетенька произносит К слов в минуту, другая тетенька С слов в минуту. Кто и на

сколько больше скажет слов за три часа если они разговаривают одновременно не слушая друг друга.

Составьте программу, реализующую эпизод применения компьютера в книжном магазине. Компьютер запрашивает стоимость книг и сумму денег, внесенную покупате

лем. Если сдачи не требуется, печатает на экране «Спасибо». Если денег внесено больше, то печатает «Возьмите сдачу» и указывает сумму сдачи. Если денег недостаточно, то печатает об этом сообщение и указывает размер недостающей суммы.

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

СПАСАЙТЕ!! ОТДАЮ ПОСЛЕДНИЕ БАЛЛЫ!!!ьЗапишите на алгоритмическом языке алгоритм построения окружности заданного радиуса r, проходящий через заданные точки

А и В.
Информатика 8 класс. Ничего не понимаю. Нужно составить алгоритм типа: взять ручку, начертить и т.д. например если фраза находится в ромбике - это вопрос, если в прямоугольнике - действие и т.д. я не понимаю как окружность должна проходить через 2 точки если неизвестно где какие точки должны находится(( ааааа( помогите пожалуйстаТОЛЬКО НЕ НАДО ПОЖАЛУЙСТА ИСКАТЬ ЧТО ТО НА ДРУГИХ САЙТАХ Т.К. Я УЖЕ СМОТРЕЛА И ТАМ НИЧЕГО НЕТ



Вы находитесь на странице вопроса "Помогите!!! 24 БАЛЛА!!! Если бы имел больше, то больше бы поставил за это решение!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.