Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1)Определить какое из двухзначных чисел имеет наибольшую сумму цифр 2)Пользователь ввёл двузнч числа.Поменяйте цифры данного числа местами 3)Проверить

5-9 класс

есть ли в трёхзначном числе два одинаковых цифры

WhispersInTheDark 09 дек. 2015 г., 9:57:23 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vnkulagin
09 дек. 2015 г., 12:53:23 (8 лет назад)

1)

var
a, b: integer;

begin
readln(a, b);
if (a div 10 + a mod 10) > (b div 10 + b mod 10) then
writeln('сумма цифр ', a, ' больше')
else
writeln('сумма цифр ', b, ' больше');
end.

2)

var
a: integer;

begin
readln(a);
writeln((a mod 10) * 10 + a div 10);
end.

3)

var
a: integer;

begin
readln(a);
if ((a div 100) = (a mod 100) div 10) or ((a div 100) = (a mod 10)) or ((a mod 100) div 10 = (a mod 10)) then
writeln('есть 2 одинаковые цифры')
else
writeln('нет 2-х одинаковых цифр');
end.

Ответить

Другие вопросы из категории

Читайте также

1.Определите,какое из указанных имен файлов удовлетворяет маске: A?ce*s.m*

1)Acess.md 2)Accesst.dbf 3)Access.mdb 4)Akcces.m1
2.Определите,какое из указанных имен файлов не удовлетворяет маске: ??pri*.?*
1)caprika.wow 2)weprik.cpp 3)otopri.c 4)reprint.be

Помогите срочно решить!

1) Городская метеостанция фиксирует температуру воздуха каждые три часа. В июле колебания температуры были в интервале от 0 до 30. Специальное устройство записывает температуру в двоичном виде с использованием минимально возможного количества бит. Каков информационный объем всех данных, записанных устройством в июле?
2) Текстовый документ, состоящий из 11264 символов, хранился в 8-битной кодировке КОИ-8. Этот документ был преобразован в 16-битную кодировку Unicode. Укажите, какое дополнительное количество Кбайт потребуется для хранения документа? В ответе запишите только число.
3) Дано а=A316, b=3018. Определите число с, записанное в двоичной системе, которое отвечает условию a 4) Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество единиц: 15 14 13 16
5) Производилась двухканальная (стерео) звукозапись с частотой дискретизации 16 кГц и 24-битнным разрешением. В результате был получен файл размером 60 Мбайт, сжатие данных не производилось. Какая из приведенных ниже величин наиболее близка к времени, в течение которого проводилась запись?
6) Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, решили использовать неравномерный двоичный код, позволяющий однозначно декодировать двоичную последовательность, появляющуюся на приемной стороне канала связи. Для букв А, Б, В и Г использовали такие кодовые слова: А – 000, Б – 001, В – 010, Г – 011. Укажите, каким кодовым словом может быть закодирована буква Д.
Код должен удовлетворять свойству однозначного декодирования. Если можно использовать более одного кодового слова, укажите кратчайшее из них.

7) Автомат получает на вход четырехзначное десятичное число. По этому числу строится новое число по следующим правилам:
1. Складываются первая и вторая, а также третья и четвертая цифры.
2. Полученные два числа записываются друг за другом в порядке убывания (без разделителей).
Пример. Исходное число: 5487. Суммы: 5+4=9; 8+7=15. Результат:159.
Определите, какое из предложенных чисел может быть результатом работы автомата.
8)Азбука Морзе позволяет кодировать символы для сообщений по радиосвязи, задавая комбинации точек и тире. Сколько различных символов можно закодировать, используя код Азбуки Морзе длиной не менее двух и не более пяти сигналов (точек и тире)?
9) Десятичное число 59 в некоторой системе счисления записывается как 214. Определите основание системы счисления.
10) при регистрации в компьютерной системе каждому пользователю выдается пароль, состоящий из 11 символов и содержащий только символы И, К, Л, М, Н. Каждый такой пароль в компьютерной программе записывается минимально возможным и одинаковым целым количеством байт (при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит).
Определите объем памяти, отводимой этой программой для записи 20 паролей.

1. Какие из перечисленных ниже устройств относятся к внешним? Монитор, процессор, оперативная память, принтер, клавиатура, жёст

кий диск, флэш-память, колонки.

2. Компьютер Вани имеет следующие характеристики:

- тактовая частота – 1,7 ГГц,

- объём оперативной памяти – 256 Мбайт.

Ваня хочет приобрести диски с компьютерными играми, на которых указаны следующие системные требования:

Диск 1. Процессор с тактовой частотой 1,5 Ггц, объём ОП – 256 Мбайт

Диск 2. Процессор с тактовой частотой 2 ГГц, объём ОП – 256 Мбайт

Диск 3. Процессор с тактовой частотой 1,7 Ггц, объём ОП – 512 Мбайт

Диск 4. Процессор с тактовой частотой 1,3 Ггц, объём ОП – 128 Мбайт.

Какие из указанных дисков Ване не стоит приобретать и почему?

3. Какова максимальная разрядность современных процессоров?

4. Расположите устройства внешней памяти в порядке убывания их объёма: CD-ROM, жёсткий диск, дискета, DVD-ROM.

5. В чём преимущества использования флэш-памяти перед другими видами внешней памяти?

Напишите программу, которая в последовательности натуральных чисел определяет сумму двухзначных чисел, кратных 5. Программа получает на вход

натуральные числа, количество введенных чисел не известно, последовательность чисел заканчивается 0.

Количество чисел не превышает 100. Введенные числа не превышают 30000.

Программа должна вывести одно число: сумму двухзначных чисел, кратных 5.

Люди! Плиииз, помогите! Т,Т



Вы находитесь на странице вопроса "1)Определить какое из двухзначных чисел имеет наибольшую сумму цифр 2)Пользователь ввёл двузнч числа.Поменяйте цифры данного числа местами 3)Проверить", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.