Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры вводится число N, а за ним N элементов массива состоящего из целых чисел.Проверить, все ли элементы массива положительны. Если да, то

10-11 класс

ввести фразу "ДА", в противном случае-"Нет".

ксения19952611 09 февр. 2017 г., 0:58:48 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sania0606
09 февр. 2017 г., 3:20:30 (7 лет назад)

program massivn;
uses crt;
type massiv=array[0..50] of integer;
var a:massiv;   
n,i,k:integer;
begin
writeln('vvedite n');
readln(n);
for i:=1 to n do begin
a[i]:=random(100)-10;
write(a[i]:3);
end;
for i:=1 to n do
if a[i]>0 then k:=k+1;
writeln;
if k=n then writeln('DA') else writeln('NET');
end.



+ 0 -
AtangulovaAina
09 февр. 2017 г., 5:18:30 (7 лет назад)

const
  C = 100;
var  n, i : Integer;
  a    : array [1..C] of Integer;
  flag : Boolean;
begin
  Write('N: ');
  Readln(n);  

  if (n < 1) or (n > C) then
  begin
    Write('Ошибка, недопустимое число.');
    Exit;

+ 0 -
Stalker0406
09 февр. 2017 г., 7:47:36 (7 лет назад)

Динамические массивы проходили?

+ 0 -
Kisa789
09 февр. 2017 г., 9:04:10 (7 лет назад)

Нет, щас повторение прошлого года!

Ответить

Другие вопросы из категории

Читайте также

Очень прошу помогите с Паскалем!)

1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3.
2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе.
3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр.
4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр.
5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+…+n.
6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов.
8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, …
9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве.
10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле».
*
* *
* * *
* * * *

* * * * * * *
11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив.
12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.

Иван и Мария взяли числа 5, 10, 28, 32 и с каждым из них выполняли следующие действия, которые называли шагом: если число четное – делили на 2,если число

нечетное – умножали его на 3 и к результату прибавляли 1.с какими из этих чисел результат 1 получится за 6 шагов?
а) 5
б) 10
в) 32
г) 28

Помогите пожалуйста ))СоставитьПомогите пожалуйста ))Составить программу по которой проверяют является ли элемент массива четным числом.Для записи

"делятся на"использовать стандартную функцию MOD,которая определяет остаток отделение числа А на число В.Примечание таблица R целочисленная.Построение блок-схемы,алгоритм и бейсики.Заранее большое спасибо))



Вы находитесь на странице вопроса "С клавиатуры вводится число N, а за ним N элементов массива состоящего из целых чисел.Проверить, все ли элементы массива положительны. Если да, то", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.