Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Срочно! Составить программу!!!

10-11 класс


Количество чисел задается пользователем:
чтобы найти среднее арифметическое надо:

1. запросить у пользователя сколько вводится чисел(N)
2. сравнить количество чисел с нулем
2.1 если количество чисел >0 (т. к. количество чисел должно быть натуральным), то:
2.1.1 т. к. мы будем находить сумму чисел, значит начальное значение следует приравнять 0
2.1.2 выполнять цикл мы будем N раз. В цикле мы должны:
2.1.2.1 запросить число(А)
2.1.2.2 к полученной сумме прибавить введенное число
2.1.3 найти среднее арифметическое введенных чисел
2.1.4 вывести полученное значение
2.2 если количество чисел <=0 то:
2.2.1 вывести сообщение об ошибке.

AleXLoLoL 15 июня 2013 г., 12:46:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Iniramustaeva
15 июня 2013 г., 13:23:10 (10 лет назад)

var
 a,sum,i,n:integer;
begin
 readln(n);
 if n<=0 then
  writeln('N не натуральное число')
 else
 begin
  sum:=0;
  for i:=1 to n do
  begin
   read(a);
   sum:=sum+a;
  end;
   writeln(sum/n);
 end;
end.

+ 0 -
0420080066
15 июня 2013 г., 14:25:40 (10 лет назад)

Ребят, умоляю

Ответить

Другие вопросы из категории

Упростить формулу (X<=>Y)*(x+y)
Написать программу на Pascale

Даны первые элементы и разности двух арифметических
прогрессий. Определить, в какой из них m-й
элемент больше (m - заданное целое
число).

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Нужно составить программу с предусловием и постусловием!

Составить программу к.т. запрашивает буквы, пока не введут точку и находит количество букв "0".



Вы находитесь на странице вопроса "Срочно! Составить программу!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.