Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Элементы массива А[i], состоящего из 20 элементов, получить по формуле 2*i^2-12*i+20 Написать программу, которая может: 1) вывести на экран все

10-11 класс

элементы получившегося массива; 2) найти минимальный и максимальный элементы; 3) вывести на экран элементы массива в обратном порядке.

Kabylda99 26 июня 2016 г., 19:42:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Verarta
26 июня 2016 г., 21:09:02 (7 лет назад)

var
a: array[1..20] of integer;
i, max, min: integer;
begin
min := 1000;
for i := 1 to 20 do begin
a[i] := 2 * (i * i) - (12 * i) + 20;
write(a[i], ' ');
if(a[i] < min) then min := a[i];
if(a[i] > max) then max := a[i];
end;

writeln('Min: ', min, ' Max: ', max);

end.

Ответить

Другие вопросы из категории

Записать на языке Pascal условие, которое является ИСТИННЫМ, когда а) каждое из чисел А и В больше 100; б) только одно из чисел А и В четное; в) хотя бы

одно из чисел А и В положительно; г) каждое из чисел А, В, С кратно трем; д) только одно из чисел А, В и С меньше 50; е) хотя бы одно из чисел А, В, С отрицательно.

1) собственное имя файла:

а)задает пользователь
б)задается программой автоматически

2) Расширение:
а)задает пользователь
б)задается программой автоматически

Дан вектор B[1:20].

А)Найти сумму S элементов в диапозоне [0:5].
Б)Найти произведение Р отрицательных элементов.
В)Поменять местами минимальный и максимальный элементы вектора.
Г)Удалить минимальный элемент.
Помогите пожалуйста решить.

Читайте также

Ввести массив F(n) вещественных

чисел. Если последний элемент массива положительный, то найти max среди
элементов массива и заменить его значений последний элемент массива. Массив
распечатать. Иначе – дать сообщение «Массив остался без изменений»

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент



Вы находитесь на странице вопроса "Элементы массива А[i], состоящего из 20 элементов, получить по формуле 2*i^2-12*i+20 Написать программу, которая может: 1) вывести на экран все", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.