Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Составить приложение на языке Pascal.

10-11 класс

С помощью ПК произвести обработку одномерного массива, заданного
в таблице. Элементы одномерного массива задать числами в диапазоне
– 20 . . . +50. Необходимо:

описать массив

ввести элементы массива из заданного диапазона;

выполнить с элементами массива действия

вывести результаты на экран.

АленаСмайлик 22 янв. 2014 г., 12:53:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Batasheva87
22 янв. 2014 г., 14:32:25 (10 лет назад)

var a:array[1..10] of integer;

i,min:integer;

Begin

  min:=1;

  for i := 1 to 10 do begin

    a[i]:= random(50+20) - 20;

    if a[i]<a[min] then min:=i;

    writeln(a[i]);

  end; 

  writeln(a[min],min);

End.

Ответить

Другие вопросы из категории

Напишіть, що це все означає

procedure TForm1.Button1Click(Sender: TObject);
begin
if edit1.Text='' then ShowMessage(Пусті значення недопустимі') else
if edit2.Text='' then ShowMessage('Пусті значення недопустимі') else
if edit3.Text='' then ShowMessage('Пусті значення недопустимі') else
if edit4.Text='' then ShowMessage('Пусті значення недопустимі') else
if edit5.Text='' then ShowMessage('Пусті значення недопустимі')else
if edit6.Text='' then ShowMessage('Пусті значення недопустимі')else
begin
edit7.Text:=floattostr(strtofloat(edit1.Text)*strtofloat(edit4.Text));
edit10.Text:=floattostr(strtofloat(edit7.Text)/100*13);
edit13.Text:=floattostr(strtofloat(edit7.Text)-strtofloat(edit10.Text));
edit8.Text:=floattostr(strtofloat(edit2.Text)*strtofloat(edit5.Text));
edit11.Text:=floattostr(strtofloat(edit8.Text)/100*13);
edit14.Text:=floattostr(strtofloat(edit8.Text)-strtofloat(edit11.Text));
edit9.Text:=floattostr(strtofloat(edit3.Text)*strtofloat(edit6.Text));
edit12.Text:=floattostr(strtofloat(edit9.Text)/100*13);
edit15.Text:=floattostr(strtofloat(edit9.Text)-strtofloat(edit12.Text));
edit16.Text:=floattostr(strtofloat(edit13.Text)+strtofloat(edit14.Text)+strtofloat(edit15.Text));
end;

end;

end.

Помогите написать в паскале!

Ввести три целых числа x, y, z. Если хотя бы одно из них четное,

то первому четному числу присвоить значение произведения этих чисел.

Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).

Ход состоит в том, что игрок перемещает фишку из точки с координатами (x,y) в одну из трех точек: или в точку с координатами (x+3,y), или в точку с координатами (x,y+3), или в точку с координатами (x,y+4). Выигрывает игрок, после хода которого расстояние по прямой от фишки до точки с координатами (0,0) не меньше 10 единиц. Кто выигрывает при безошибочной игре – первый или второй игрок? На каком шаге игры произойдет выигрыш? Каким должен быть первый ход выигрывающего игрока?

составьте блок-схему и программу для решения следующей задачи. Введите с клавиатуры два числа: к и л. Если они положительны, то замените каждое на квадрат

их суммы и выведите результаты на экран. Если все числа отрицательны, то каждое сделайте равным наименьшему и выведите результаты. Иначе, К приравняйте к 10, а Л - к 15 и выведите результаты

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Составить приложение на языке Pascal.Определить в какую четверть координатной плоскости

попала точка с координатами (x,y). Переменной N
присвоить номер четверти. Если точка попала в начало
координат, то N=0. Если точка попала на ось X или Y, то
напечатать сообщение об этом.

Составить приложение на языке Pascal. Вычислить на ПК значения функции, заданной в таблице. На печать

вывести значения вводимых исходных данных и полученные результаты,
сопровождая их именами переменных. Значения аргумента взять из
указанного диапазона так, чтобы протестировать все ветви программы.

Помогите составить программу на языке PASCAL

В матрице X(5×5) определите произведение положительных элементов
главной диагонали.



Вы находитесь на странице вопроса "Составить приложение на языке Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.