Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дан двумерный массив a, раз­мером (n´n)(или

10-11 класс

квадратная мат­рица а). Найти сумму номеров минимального и максимального элементов её глав­ной диаго­нали.

Ivanlili 19 сент. 2014 г., 4:06:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Undine
19 сент. 2014 г., 7:00:43 (9 лет назад)

program cgt;
var a:array[1..100,1..100]of integer;
max,min,s,i,j,n,x1,y1,x2,y2:integer;
begin
read(N);
for i:=1 to n do
for j:=1 to n do
read(a[i,j]);
max:=a[1,1];
min:=a[1,1];
for i:=1 to n do
begin
for j:=1 to n do
begin
if(i=j)and(a[i,j]>=max)then begin
max:=a[i,j];
x1:=i;
y1:=j;
end;
if(i=j)and(a[i,j]<=min)then begin
min:=a[i,j];
x2:=i;
y2:=j;
end;
end;
end;
s:=x1+x2+y1+y2;
writeln(s);
end.

Ответить

Другие вопросы из категории

Помогите решить позя)
Написать программу, которая выводит таблицу квадратов первых десяти целых положительных чисел (естественно, квадраты должны считаться В ЦИКЛЕ!). Ниже

представлен вид экрана во время работы программы, который вам нужно реализовать:

Таблица квадратов
-----------------------------
Число Квадрат
-----------------------------
1 1
2 4
и т.д.

1100110101,1(2) – 1011100011,01(2)

Читайте также

Дан двумерный массив a, разме­ром (n´n)(или квадратная мат­рица

а). Найти среднее арифметиче­ское положительных элементов, ниж­ней треугольной
матрицы, располо­женной ниже главной диагонали, ис­ключая саму главную
диагональ.

Дан двумерный массив

размерностью n х m,
заполненный случайными числами. Определить, есть ли в данном массиве строка,
содержащая больше положительных элементов,
чем отрицательных. Ответ: «Есть» или «Нет».
Если можно решите попроще, каждая отдельная операции через подпограмму

Дан двумерный массив целых числе i=10 j=15, Заполняется случайным образом целыми числами от 0до 100. 1) Определить сколько раз в нем встречается

элемент со значеием х. х задается прользователем

2) Определить количесво четных элементов массива.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.



Вы находитесь на странице вопроса "Дан двумерный массив a, раз­мером (n´n)(или", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.