Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Вводится двузначное число с клавиатуры.Найти сумму цифр этого числа и проверить,является эта сумма четным числом или нет.Помогите пожалуйста:(

5-9 класс

TanyaMilaya000 17 апр. 2015 г., 8:55:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SMa20178
17 апр. 2015 г., 10:21:26 (9 лет назад)

var
  n, sum :integer;

begin

  readln(n);
  sum:= (n div 10) + (n mod 10);
  write(sum,' - ');
  if sum mod 2 = 0 then
    write('четная')
  else
    write('нечетная');

end.

Ответить

Другие вопросы из категории

Помогите,пожалуйста! очень надо!!!!

1. Заполнить двумерный массив размером ( 5, 11 ) целыми числами. Найти сумму положения элементов массива по главной диагонали. Вывести матрицу на экран.

2. Заполнить одномерный массив значением функции у=2 кв. корень из модуль х-2. Х=1,3,5...21. Вывести массив на экран в одну сторону. Найти сумму элементов массива.

Читайте также

Составьте программу,которая определяет,является ли сумма цифр введенного целого трехзначного числа четным числом.

Пример ввода:567.
Пример вывода:сумма цифр числа 567-четное число

Помогите, пожалуйста, по Паскалю! 21. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение.

После этого компьютер должен напечатать текст ЗАДАЧА РЕШЕНА.

22. В компьютер вводятся длины трех отрезков. Компьютер должен ответить на вопрос, правда ли, что пер-вый отрезок не слишком длинен, чтобы образовать с другими двумя отрезками треугольник. Указание: Для этого его длина должна быть меньше суммы длин двух других отрезков. Замечание: Пока не думайте о том, что слишком длинными могут быть второй или третий отрезки. Об этом – задание из 5.5.



Вы находитесь на странице вопроса "Вводится двузначное число с клавиатуры.Найти сумму цифр этого числа и проверить,является эта сумма четным числом или нет.Помогите пожалуйста:(", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.