Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано целое число N (> 0). Найти сумму 1 + 1/2 + 1/3 + … + 1/N (вещественное число).

5-9 класс

Nurohkasher 14 нояб. 2015 г., 11:41:52 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89236472888
14 нояб. 2015 г., 13:07:10 (8 лет назад)

var
i,n:integer;
s:real;
begin
writeln('Введите N:');
readln(n);
s:=1;
for i:=2 to n do
s:=s+1/i;
writeln('сумму:', s);
end.

Ответить

Другие вопросы из категории

помоги срочно даю 50 балов
Автоматическое устройство осуществило перекодировку информационного сообщения на русском языке первоначально записанного в 16-битном коде unicode в

8-битную кодировку windows-1251. При этом информационный объем сообщения составил 60 байт. Определите информационный объем в байтах сообщения до перекодировки

Читайте также

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа

a,b,c,d.Выяснить произведение этих чисел больше 300? 3)Дано целое число ,если оно положительное,то прибавить к нему 1,а если отрицательное.то отнять от него 2.Вывести полученое число.

Введите целое число и найти сумму его цифр.

Пример:
Введите целое число:
1 2 3 4
Сумма цифр числа 1 2 3 4 равна 10



Вы находитесь на странице вопроса "Дано целое число N (> 0). Найти сумму 1 + 1/2 + 1/3 + … + 1/N (вещественное число).", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.