Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите написать программу которая отсортировывает последовательность нескольктх чисел и выясняет на сколько максимальный элемент больше минимального

5-9 класс

Fkfkkffj 15 дек. 2013 г., 19:34:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karina20023
15 дек. 2013 г., 21:14:01 (10 лет назад)

var  b:array[1..100] of integer;
      c:array[1..100] of integer; 
n, a,max,min,i,j,nom:integer;
sort: boolean;
begin
writeln('введите количество чисел');
readln(n);
writeln('введите числа');
readln(b[1]);
max:=b[1];
nom:=1;
min:=b[1];
for i:=2  to n do
begin 
readln(b[i]);
if b[i]<min then begin min:=b[i];nom:=i end;
if b[i]>max then max:=b[i];
end;
writeln(max-min);

c[1]:=min;
b[nom]:=max+1;

for j:=2 to n do 
 begin
min:=max+1;
for i:=1 to n do
if b[i]<min then begin min:=b[i];nom:=i;
c[j]:=min;
b[nom]:=max+1;
end;
for i:=1 to n do
write(c[i],'   ');
end.

Ответить

Другие вопросы из категории

решите задачу по информатике:

Robot cif17
пожалуйста очень надо срочно

2.Определите информационный объем звукового файла,если файл длится 1 минуту и звуковой картой с частотой 32 КГц и разрешением 8 бит воспроизводится

стереозвук.Ответ запишите в КБайтах.
3.Определите количество цветов в картинке,если её информационный объем 703,125 Кбайт,а разрешение графического редактора 800*600.

срочно люди:

приведите примеры актуальной , достоверной информации используемой в повседневной жизни

Помогите пожалуйста.

Выразите 128Кбайт в Мбайт

Читайте также

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal



Вы находитесь на странице вопроса "помогите написать программу которая отсортировывает последовательность нескольктх чисел и выясняет на сколько максимальный элемент больше минимального", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.