Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Сделайте пожалуйста блок-схему или код в small basic. Дан массив из 20 целых чисел. В массиве хранятся результаты соревнований по спортивной стрельбе.

10-11 класс

Один элемент массива соответствует количеству очков, набранных одним участником соревнований, и имеет значение от 0 до 30 включительно. Необходимо разработать программу, которая по данным массива вычисляет максимальное количество очков среди участников соревнований, и количество участников набравшее зачётное количество очков. Зачётное количество очков 18. Гарантируется, что хотя бы один участник соревнований набрал зачётное количество очков.

Qazwsxedc7 30 июня 2014 г., 13:38:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aboimova2011
30 июня 2014 г., 14:39:55 (9 лет назад)

var a:array[1..20]of integer;
i,s,max:integer;
begin
for i:=1 to 20 do a[i]:=random(31);
for i:=1 to 20 do write(a[i],' ');
writeln;
for i:=1 to 20 do begin
if a[i]>=18 then s:=s+1;
if a[i]>max then max:=a[i];
end;
writeln(max,' ',s);
end.

Ответить

Другие вопросы из категории

пожалуйста помогите и пишите понятно!!!!

1 задания: перевидите числа в десятичную систему счисления
а) 10101011 в степени 2
б) 1011,101 в степени 2
2 задания: переведите число 1011001011110010 в степени 2
а) в восьмеричную систему счисления
б) в 16-ричную систему счисления
3 задания:выполнить действия
а) 10110,11 в степени 2 + 1101,01 в степени 2
б) 101 в степени 2 умножить 111 в степени 2!

22. Дан фрагмент программы, обрабатывающий массив А из 10 элементов: n := 10; for i:=1 tо n do A[i] := i; j := 1; for i:=1 tо n-1 do if A[i] < A[i+1]

then j := j + 1; Чему будет равно значение переменной j после выполнения этого алгоритма?

A 8 Про­из­во­дит­ся од­но­ка­наль­ная (моно) зву­ко­за­пись с ча­сто­той дис­кре­ти­за­ции 16 кГц и 32-бит­ным раз­ре­ше­ни­ем. За­пись длит­ся

8 минут, ее ре­зуль­та­ты за­пи­сы­ва­ют­ся в файл, сжа­тие дан­ных не про­из­во­дит­ся. Какое из при­ве­ден­ных ниже чисел наи­бо­лее близ­ко к раз­ме­ру по­лу­чен­но­го файла, вы­ра­жен­но­му в Мбай­тах?

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "Сделайте пожалуйста блок-схему или код в small basic. Дан массив из 20 целых чисел. В массиве хранятся результаты соревнований по спортивной стрельбе.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.