Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Вводится число. Требуется вывести его так, чтобы составляющие его цифры шли в обратном порядке. Например, вводится число 4096, надо вывести 6904.Если

5-9 класс

найти остаток от деления на 10, то мы получим последнюю цифру числа.Запишем эту цифру в новое число.Разделим старое число нацело на 10, так мы избавимся от последней цифры в нем.Снова найдем остаток от деления на 10. Получим вторую с конца цифру исходного числа.Если мы умножим новое число на 10, то получим "дополнительный" младший разряд, куда можем записать вторую цифру исходного числа (простым сложением).Будем повторять вышеописанные действия пока исходное число не станет равным нулю.

ОБЪЯСНИТЕ КАК ЭТО СДЕЛАТЬ! ПОДРОБНО!

Anafray 12 авг. 2015 г., 15:50:02 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gdnb
12 авг. 2015 г., 17:05:59 (8 лет назад)

var a:integer;
begin
readln(a);
while(a<>0) do begin
write(a mod 10);
a:=a div 10;
end;
end.

+ 0 -
Needforsteb
12 авг. 2015 г., 18:22:09 (8 лет назад)

Комментарий удален

+ 0 -
Faesbyk
12 авг. 2015 г., 19:42:39 (8 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите, пожалуйста, с задачей.

Первый файл имеет информационный объём 2 Кбайта, второй – 101 байт. Каков общий объём в байтах этих двух файлов?

N1 имеется 4 вида ракет, разных цветов. Сколько различных сигналов можно передать с помощью 3 запущенных ракет?

N2 требуется передать 31 сигнал. Сколько для этого нужно 2х цветных ламп?
N 3 придумайте и нарисуйте обозначения для понятий "человек", "радость", "мир", "война"

первое задание не могу решить

Читайте также

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2

Напишите программу, которая вводит число, не превышающее 45,

и определяет, изменяется ли сумма цифр этого числа при умножении его
на два. Ответ прикрепите в виде файла в среде PascalABC.

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

Здравствуйте.Помогите,пожалуйста,решить задачи в Паскале.Вот: Ввести с клавиатуры несколько дробных чисел, признак окончания ввода – число

1000.Нужно изменить программу так,чтобы она находила:

а) дробную часть чисел;

б) произведение чисел, меньших 22;

в) сумму чисел, которые попадают в промежуток [10, 50]. Заранее,спасибо большое!)))))



Вы находитесь на странице вопроса "Вводится число. Требуется вывести его так, чтобы составляющие его цифры шли в обратном порядке. Например, вводится число 4096, надо вывести 6904.Если", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.