Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

5-9 класс

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Jefven 22 окт. 2013 г., 22:06:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Monikina
23 окт. 2013 г., 0:29:19 (10 лет назад)

1)var t: array [1..12] of real;

      i: integer;

begin

  for i:=1 to 12 do readln(t[i]);

  writeln('Средняя температура зимних месяцев: ',((t[12]+t[1]+t[2])/3):0:3);

  writeln('Средняя температура весенних месяцев: ',((t[3]+t[4]+t[5])/3):0:3);

  writeln('Средняя температура летних месяцев: ',((t[6]+t[7]+t[8])/3):0:3);

  writeln('Средняя температура осенних месяцев: ',((t[9]+t[10]+t[11])/3):0:3);

end.

2)var t: array[1..10] of integer;

         c: array[1..10] of real;

         i: integer;

         s,s1: real;

begin

  s:=0;

  for i:=1 to 10 do begin writeln('Введите количество товара'); readln(t[i]) ; end;

  for i:=1 to 10 do begin writeln('Введите цену товара');readln(c[i]);end;

  for i:=1 to 10 do begin s1:=t[i]*c[i];

                                    s:=s+s1;

                           end;

  writeln('Общая стоимость всех покупок: ',s:0:3);

end.

Ответить

Другие вопросы из категории

1. Выполни

алгоритм по заданной блок-схеме (задание в приложении).

Задачи по информатике. Решите пожалуйста что сможите.!! 1. Количество экзаменационных билетов по информатике – 32. Сколько

информации содержит сообщение о том, что ученик вытащил 13
билет?


2. Сообщение о том, что из коробки вынули наугад 1 шар и он оказался
красным, содержит 4 бита информации. Сколько разноцветных шаров
было в коробке?


3. Текст, набранный в редакторе Блокнот, содержит 4 страницы по 2000
символов на каждой. Найдите объем текста в байтах и килобайтах.


4. Какой из двух рисунков в формате *.bmp (без дополнительного сжатия)
занимает больше места на диске:
А) 300 х 200 (пикселей) при 8-цветной палитре или
Б) 120 х 100 (пикселей) при 256-цветной палитре?

___________________________________________________

Каково

количество кодовых комбинаций символов алфавита, если разрядность
двоичного кода равна 7

Это цикл for:

1)даны натуральные числа X и Y.вычислить X*Y,пользуясь только оперцией сложения.
2)даны натуральные числа X и Y.вычислить X^Y
3)дано натуральное число N. найти сумму S=1+1/2+1/3+...+1/N.

4)дано натуральное число N и число Х.найти сумму S=(X+1)^2+(X+2)^2+...+(X+N)^2

Читайте также

Помогите решить задачку в паскале ! Пожалуйста !

Составить программу на языке Pascal для решения следующей логической задачи.
По графику нужно написать задачу и решение, график прилагается.

Помогите решить задачи на паскаль.

1)
Дан массив случайных чисел (количество элементов
вводите с клавиатуры). Найти произведение всех элементов массива.



Вы находитесь на странице вопроса "Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.