Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Дано натуральное число N.Определить , является ли оно совершенным (совершенное число равно сумме всех своих делителей , не превосходящих само число)

10-11 класс

Vovaskv 03 дек. 2013 г., 7:03:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ksenya13129
03 дек. 2013 г., 9:45:55 (10 лет назад)

var numb,k,summa:integer;
begin
readln(numb);
for k:= 1 to (numb-1) do
begin
if numb mod k = 0 then
summa:=summa+k;
end;
if summa = numb then
writeln('Совершенное')
else
writeln('Несовершенное');
end.

+ 0 -
Помогите900
03 дек. 2013 г., 11:56:59 (10 лет назад)

можно пример совершенного числа?

+ 0 -
Cbbhngjhvcv
03 дек. 2013 г., 14:52:25 (10 лет назад)

вроде бы подходит)

Ответить

Читайте также

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.



Вы находитесь на странице вопроса "Дано натуральное число N.Определить , является ли оно совершенным (совершенное число равно сумме всех своих делителей , не превосходящих само число)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.