Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

напишите программу которая считывает с клавиатуры n чисел и затем и затем выводит на экран сумму и среднее арифметическое считанных чисел.

5-9 класс

Mileykatrina 08 авг. 2014 г., 4:33:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bloodmen666
08 авг. 2014 г., 5:31:56 (9 лет назад)

Паскаль:
var a,b,n,k:integer;
begin
readln (n);
for a:=1 to n do
begin
readln (b);
k:=k+b;
end;
writeln (k);
k:=k/n;
writeln (k);
end.

+ 0 -
Dusko
08 авг. 2014 г., 8:21:21 (9 лет назад)

паскаль?

+ 0 -
Kaliriya
08 авг. 2014 г., 10:50:54 (9 лет назад)

да

Ответить

Другие вопросы из категории

ИЗ ОПЕРАТИВНОЙ ПАМЯТИ(ОЗУ) ЗАПИСАЛИ ИЗОБРАЖЕНИЯ НА ВЛЕШ КАРТУ.СКОЛЬКО СВОБОДНОЙ ПАМЯТИ В ОЗУ ОСТАНЕТСЯ ПОСЛЕ ОПЕРАЦИИ ЗАПИСИ,ЕСЛИ ОДНО ИЗОБРАЖЕНИЕ

ЗАНИМАЕТ 16 Кбайт? выбери правильный ответ 1) 80 КБАЙТ 2) 96КБАЙТ 3)112 КБАЙТ 4) ВСЕ ЯЧЕЙКИ БУДУТ СВОБОДНЫ

вывести на экран номер всех счастливых билетов и подсчитать сколько их? В чем ошибка?

var a,b,c,d,f,e,n:longint; k:real;begink:=0;for n:=000001 to 999999 do begin a:= n mod 10;b:= n div 10 mod 10;c:= n div 100 mod 10;d:= n div 1000 mod 10;f:= n div 10000 mod 10;e:= n div 100000 mod 10;if(a+b+c=d+f+e) then begin writeln(n);k:=k+1;end;end;end.
покупатель должен заплатить в кассу S рублей . У него есть купюры в 1,2,5,10,50,100,500 руб. Найти наименьшее кол-во , которым он может рассчитаться? Помогите пожалуйста!

Выберите устройство ПК. которое по функциям можно сравнивать с мозгом человека:

А) видеокарта Б) звуковая карта
В) процессор Г) винчестер

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!



Вы находитесь на странице вопроса "напишите программу которая считывает с клавиатуры n чисел и затем и затем выводит на экран сумму и среднее арифметическое считанных чисел.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.