Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Помогите написать программу вычисления длин медиан треугольника со сторонами длиной а,b,c.

5-9 класс

вот формула:1/2*квадратный корень из 2*a^2+2*c^2-b^2
как то так

Sam1228 23 мая 2015 г., 14:50:03 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yustya
23 мая 2015 г., 17:14:28 (8 лет назад)

var a, b, c : integer;
function mediana(a, b, c : integer) : real;
begin
  mediana := 0.5 * sqrt(2 * a * a + 2 * c * c - b * b);
end;
Begin
  readln(a, b, c);

  writeln(mediana(a,b,c));
  writeln(mediana(a,c,b));
  writeln(mediana(b,c,a));
End.

Ответить

Другие вопросы из категории

Дана последовательность из n вещественных чисел, начинающаяся с отрицательного числа.

Определить, какое количество отрицательных чисел записано в начале последовательности.
Условный оператор не использовать. ПАСКАЛЬ. НУжно без массивов и так далее.
ТЕМА ЦИКЛ

История плечевой одежда. Древняя Русь.( только картинки!!!)

30 баллов даю
помогите плиз
технология

Создайте два HTML-документа на произвольную тему,

свяжите их гиперссылками, как показано в примере 3.1. Один из документов должен
содержать внутреннюю ссылку и "прицельную" ссылку на второй документ.
Для проверки ее работы целесообразно ввести большой фрагмент текста, либо
просто заполнить страничку каким – либо символом. Отметим, что внутренняя
ссылка не покажет своего действия, если текст в Вашем документе не выходит за
пределы видимости.

Читайте также

Написать программу Turpo pascal помогите пожалуйста что сможете!!! Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу

вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.

Определение факториала:

0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.

Другими словами n!- это произведение n натуральных чисел.

1)Написать программу вычисления модуля разность двух данных целых чисел 2)Составить программу вычесляет в котором n суток, часов, минут,

секунд.

3)Составте программу вычисления площади треугольника с основанием а и высотой h. Значение a и h введите с клавиатуры.

Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). Программист торопился и

написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится пять ошибок:

k:=1;

f:=0;

while k<n do

f:=f*k;

k:=k+1



Вы находитесь на странице вопроса "Помогите написать программу вычисления длин медиан треугольника со сторонами длиной а,b,c.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.