Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

определить зарплату работнику по больничному листу, проболевшему К дней при следующих условиях, если стаж

10-11 класс

работы

до 6 лет – 60%,

от 6-8 – 80%,

более 8 – 100 %,

если несовершеннолетний –100 %,

зарплата работника Z рублей в день.

LenaDan98 30 сент. 2014 г., 2:02:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Artyr86rus
30 сент. 2014 г., 3:06:54 (9 лет назад)

Я напишу полную зарплату, учитывая зарплату полных рабочих дней, и тех, что он был на больничном, не учитывая выходные дни, но учитывая количество дней в месяце.

 

Код для Visual Basic(на платформе .Net)

 

Sub Zaprlata

Dim K , Staj, Z, Zarplata, Dni, Vozrast As Integer

 

K = InputBox("Введите количество больничных дней")

Z = InputBox("Введите заработную плату в день")

Staj = InputBox("Введите стаж работы(кол-во лет)")

Dni = InputBox("Введите количество дней в месяце")

Vozrast = InputBox("Введите возраст рабочего")

If Staj < 6 Then 

Zarplata = (Dni-K)*Z + K*(0.6*Z)

ElseIf Staj > 6 And staj < 8 Then

Zarplata = (Dni-K)*Z + K*(0.8*Z)

ElseIf Staj > 8 Or Vozrast < 18 Then 

Zarplata = Dni * Z

End If 

End Sub

+ 0 -
плюшка32
30 сент. 2014 г., 4:30:35 (9 лет назад)

Паскаль

 

uses crt;
var m:string; k,l,z:real;
begin
clrscr;
writeln('Укажите количество дней.'); read(k);
writeln('Укажите зарплату работника.'); read(z);
writeln('Работник совершеннолетний? да/нет.');
read(m);
if (m='да') then write('Зарплата составит  ',z,'руб.');
if (m='нет') then
begin
writeln('Укажите стаж работы'); read(l);
if l<6 then write('Зарплата составит ',z*0.6,'руб.');
if l>8 then write('Зарплата составит ',z,'руб.')
else write('Зарплата составит ',z*0.8,'руб.');
end;
end.

Ответить

Другие вопросы из категории

золотое правило механики
Qbasic помогите составить программу

Напишите программу, запрашивающую у пользователя три разных целых положительных числа и находящую сумму двух меньших из них

большой жёлтый круглый овощ
1. Какие пары объектов находятся в отношении "объект - модель"?

А) компьютер – данные;
Б) компьютер - его функциональная схема;
В) компьютер – программа;
Г) компьютер – алгоритм.
2. Какая модель компьютера является формальной (полученной в результате формализации)?
А) техническое описание компьютера;
Б) фотография компьютера;
В) логическая схема компьютера;
Г) рисунок компьютера.
3. Информационной моделью, которая имеет табличную структуру является ...
А) файловая система компьютера;
Б) таблица Менделеева;
В) генеалогическое дерево семьи;
Г) функциональная схема компьютера.
4. Какая модель является динамической (описывающей изменение состояния объекта)?
А) формула химического соединения;
Б) формула закона Ома;
В) формула химической реакции;
Г) закон Всемирного тяготения.

Читайте также

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)



Вы находитесь на странице вопроса "определить зарплату работнику по больничному листу, проболевшему К дней при следующих условиях, если стаж", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.