Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите создать алгоритм, распознающий сколько раз в слове "жекеленген" встречается "ен" (Паскаль). ПОЖАЛУЙСТА!!! У меня спорная(((

5-9 класс

DanilDanilk 25 марта 2015 г., 15:34:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vadimka88888
25 марта 2015 г., 16:17:20 (9 лет назад)

program fofgogjoj;
var  S,Sw:string; 
i,j,Len1,Len2,Cnt:integer;
begin 
Writeln('Введи строку:'); 
Readln(S); 
Writeln('Введи подстроку:'); 
Readln(Sw);  
Len1:=Length(S); 
Len2:=Length(Sw); 
Cnt:=0; 
for i:=1 to Len1-Len2+1 do
begin   
j:=1;   
while j<=Len2 do
begin     
if S[i+j-1] <> Sw[j] then Break;     
Inc(j);   
end;   
if j > Len2  then
Inc(Cnt); 
end;  
Writeln('Количество вхождений: ', Cnt); 
end.

Ответить

Другие вопросы из категории

СРОЧНО

Ребят, помогите пожалуйста.
Нужно написать программу (или программы) для вычисления суммы, произведения и среднего арифметического для трех чисел.

Помогите решить пожалуйста
В небольшом городке живут пятеро друзей: Иванов, Петров, Сидоров, Гришин и Алексеев. Профессии у них разные: один из них - маляр, другой - мельник,

третий - плотник, четвертый - почтальон, пятый - парикмахер. Петров и Гришин никогда не держали в руке малярной кисти. Иванов и Гришин все собираются посетить мельницу, на которой работает их товарищ. Петров и Иванов живут в одном доме с почтальоном. Иванов и Сидоров каждое воскресенье играют в городки с плотником и маляром. Петров брал билеты на футбол для себя и для мельника. Определите профессию каждого из друзей.

Читайте также

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

ПОМОГИТЕ создать шапку таблицы!

Продумайте структуру таблицы для решения следующей задачи:В пещере у реки поселился огнедышащий дракон по имени Сергей Михайлович. Всех, кто пытался его прогнать, он прогонял сам, полыхая огнем. Количество полыханий зависело от того, на кого надо полы­хать. На царевича дракон полыхал 5 раз, на королеви­ча — 4 раза, на простого рыцаря — 3. За первые сто лет дракона пытались прогнать 2 цареви­ча, 3 королевича и 5 простых рыцарей. За второе сто­летие на него покушались 3 царевича, 2 королевича и7 простых рыцарей. За третий век дракона беспокои­ли 7 царевичей, 5 королевичей и 6 простых рыцарей. За следующее столетие Сергею Михайловичу при­шлось иметь дело с 3 царевичами, 6 королевичами и 10 простыми рыцарями. После чего дракона, в конце концов, оставили в покое и объявили гору, на которой он жил, заповедником для охраны редких видов жи­вотных.Сколько человек пытались прогнать дракона за каж­дое из столетий в отдельности и за все 4 века вместе? Сколько среди них было царевичей, сколько короле­вичей и сколько простых рыцарей? Сколько раз дракону пришлось полыхать на них ог­нем в течение каждого века и за все 4 столетия вмес­те? Сколько полыханий досталось царевичам, сколь­ко — королевичам и сколько — простым рыцарям?

• 1В процессе преобразования растрового графического изображения количество цветов уменьшилось с 64 до 8. Во сколько раз уменьшился объем, занимаемый

им в памяти. Контрольная работа по теме «Компьютерная графика» 2 вариант • 2Мультимедиа – это А) получение движущихся изображений на дисплее; Б) прикладная программа для создания и обработки рисунков; В) объединение высококачественного изображения с реалистическим звуком; Г) область информатики, занимающаяся проблемами рисования на ЭВМ. • 3Выберите правильную последовательность этапов развития компьютерной графики: а) Появление графических дисплеев; b) Символьная графика; c) Появление графопостроителей; d) Появление принтера цветной печати. А) a, c, d, b; Б) b, c, a, d; С) b, a, c, d; Г) a, b, d, c. 3. Созданием произвольных рисунков, чертежей занимается А) научная графика; Б) конструкторская графика; В) деловая графика; Г) иллюстративная графика. 4. Какое устройство компьютера осуществляет процесс дискретизации звука? А) звуковая карта; Б) колонки; В) наушники; Г) процессор. 5. Растровое изображение представляет из себя … А)мозаику из очень мелких элементов — пикселей; Б) сочетание примитивов; В) палитру цветов. 6. Точка графического экрана может быть окрашена в один из цветов: красный, зелёный, коричневый, чёрный. Какой объём видеопамяти будет выделен для кодирования каждого пикселя? А) 4 бита; Б) 2 байта; В) 4 байта; Г) 2 бита; Д) 3 бита. 7. Инструментом ГР является: А) Линия; Б) цвет; В) разбрызгиватель; Г) рисунок. 8.Графическим примитивом является: А)линия; Б)ластик; В) копирование; Г)цвет. 9. Для получения 4-х цветного изображения на каждый пиксель необходимо выделить А) 1 байт ; Б) 1 бит; В) 2 байта; Г) 2 бита 10.Дискретный сигнал – это …А) цифровой сигнал; Б) количество измерений, производимых прибором за 1 секунду; В) непрерывно меняющееся со временем значение физической величины; Г) таблица с результатами измерений физической величины в фиксированные моменты времени. 11. При какой частоте дискретизации происходит более точное воспроизведение звука? А) 44,1 кГц; Б) 11 кГц; В) 22 кГц; Г) 8 кГц. 12. Что можно отнести к недостаткам растровой графики по сравнению с векторной? А) Большой объём графических файлов. Б) Фотографическое качество изображения. В) Возможность просмотра изображения на экране графического дисплея. Г) Искажения при масштабировании. 13.Что можно отнести к недостаткам ж\к монитора? А) малый вес; Б) затемнения при изменении угла обзора; В) отсутствие э/м излучения; Г) малый объем. • 14Для кодирования зелёного цвета служит код 1011. Сколько цветов в палитре? • 15Найдите объём записываемого звукового квадроаудиофайла, если запись велась 4 минуты, с использованием 16-битовой глубины кодирования звука и частотой дискретизации 32кГц. • 16Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения? • 17 В процессе преобразования растрового графического файла количество цветов уменьшилось с 512 до 8. Во сколько раз уменьшился информационный объем файла?

Помогите с задачей(( В ящике имеется 3 черных и 5 белых шаров. Какое наименьшее число шаров нужно взять из ящика (не заглядывая в него) , чтобы

среди вытянутых шаров:

1) оказался хотя бы один черный _____ -сколько раз?

2) оказался хотябы один белый ________ -сколько раз?

3) оказались хотя бы 2 черных ___

4) оказались хотябы 2 белых?

Помогите((

Помогите решить:

Сколько раз на экран выведется слово Hello?
for i= -2 to 7 do
writeln(,Hello,);



Вы находитесь на странице вопроса "Помогите создать алгоритм, распознающий сколько раз в слове "жекеленген" встречается "ен" (Паскаль). ПОЖАЛУЙСТА!!! У меня спорная(((", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.