Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста с информатикой 7 класс (Паскаль, Условный оператор)

5-9 класс

Задача : Запрашивается стоимость книги и внесённая оплата, если оплата совпадает со стоимостью, то пишется "спасибо". Если оплата меньше, то пишется "добавьте денег".
Если оплата больше стоимости то пишется "возьмите сдачу" и сумма сдачи.

Zaikovskaya 17 июля 2016 г., 10:16:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ooozzzyyy
17 июля 2016 г., 12:30:05 (7 лет назад)

program oplata;
var a,b:integer; 
 begin 
writeln('Введите  стоимость '); 
readln(a); 
writeln('Введите  оплату '); 
readln(b); 
if a=b then writeln('спасибо') 
          else  if a>b then writeln('добавьте денег')
                           else writeln('возьмите сдачу')
end.

Ответить

Другие вопросы из категории

Какое кол-во информации получит второй игрок после первого хода первого игрока в игре

"Крестики-нолики" на поле размером 4х4 ?

Даны два числа а=2248

и

Читайте также

Здравствуйте!Помогите пожалуйста с информатикой!

1.В ящике имеется 3 чёрных и 5 белых шаров.Какое наименьшее число шаров нужно взять из ящика ( не заглядывая в него), чтобы среди вытянутых шаров:.
1)Оказался хотя бы 1 чёрный
2)Оказался хотя бы 1 белый
3)Оказались хотя бы 2 чёрных
4)Окаазались хотя бы 2 белых
Если можно с решением,логическим рядом.
2. В одной книге было написано 100 следующих утерждений.
"В этой книге роно одно неверное утверждение"
"В этой книге ровно два неверных утверждения"
............................................................................................
"В этой книге ровно сто неверных утверждений.

Какое из этих утерждений верное?

Судя по моим мыслям,это явно не 3, тогда это получается правда, что противоречит смыслу предложения. Тогда какое получается? Я не знаю.Помогите пожалуйста. Напишите всё с решением пожалуйста.



Ах да,чуть не забыла. Если кто -то знает бесплатный решебник ( без всяких файлообменников) напишите пожалуйста.

Здравствуйте!Помогите пожалуйста с информатикой! 1.В ящике имеется 3 чёрных и 5 белых шаров.Какое наименьшее число шаров нужно взять из ящика ( не

заглядывая в него), чтобы среди вытянутых шаров:. 1)Оказался хотя бы 1 чёрный 2)Оказался хотя бы 1 белый 3)Оказались хотя бы 2 чёрных 4)Окаазались хотя бы 2 белых Если можно с решением,логическим рядом. 2. В одной книге было написано 100 следующих утерждений. "В этой книге роно одно неверное утверждение" "В этой книге ровно два неверных утверждения" ............................................................................................ "В этой книге ровно сто неверных утверждений. Какое из этих утерждений верное? Судя по моим мыслям,это явно не 3, тогда это получается правда, что противоречит смыслу предложения. Тогда какое получается? Я не знаю.Помогите пожалуйста. Напишите всё с решением пожалуйста. Ах да,чуть не забыла. Если кто -то знает бесплатный решебник ( без всяких файлообменников) напишите пожалуйста.

помогите пожалуйста с информатикой вот такие задачки:

Линейные программы.
Напишите программу на ШАЯ. Вычислите площадь боковой поверхности куба. S=4a(в квадрате)
Условный оператор (ветвление)
Нарисуйте блох-схему. Найдите решение уравнения ax+b=0 если оно отсутствует.
Циклы
Напишите программу на Паскале. Вводится последовательность из N целых чисел. Сколько отрицательных чисел и сумма положительных чисел?
Одномерные массивы
Напишите программу на паскале. В одномерном массиве вычислите сумму положительных элементов.
Двумерные массивы
Напишите программу на паскале. Дан квадратный целочисленный массив. Уменьшить в два раза все его элементы.

Если что извините, надеюсь не много прошу.



Вы находитесь на странице вопроса "Помогите пожалуйста с информатикой 7 класс (Паскаль, Условный оператор)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.