Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

помогите написать задачу в паскале АBC в файле 1.txt находятся английские слова (записаны столбиком) а в файле 2.txt находятся их русский перевод

10-11 класс

запускаем программу вводим английское слова программа должна выдать на экран русский перевод

An28082003 25 июня 2015 г., 12:22:19 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alysseum
25 июня 2015 г., 15:02:19 (8 лет назад)

const N=100;
var eng,rus:array[1..N] of string;
i:integer;
slovo:string;
file1,file2:text;
begin
  assign(file1,'1.txt');
  assign(file2,'2.txt');
  reset(file1);
  reset(file2);
  for i:=1 to N do
    begin
      readln(file1,eng[i]);{считываем очередное слово из первого файла}
      readln(file2,rus[i]);{считываем перевод этого слова из второго файла}
    end;
  writeln ('Введите английское слово ');
  read(slovo); {пользователь вводит слово}
  for i:=1 to N do
    if slovo=eng[i] then
        Writeln('Слово ',eng[i],' переводится как ',rus[i]);
  close(file1);
  close(file2); {заканчиваем работу с файлами}  
end.

+ 0 -
Alexegorov01
25 июня 2015 г., 16:58:00 (8 лет назад)

const N=1000;
var a,b:array[1..N] of string;
i:integer;
sl:string;
f1,f2:text;
begin
assign(f1,'1.txt');
reset(f1);
for i:=1 to N do
readln(f1,a[i]);
assign(f2,'2.txt');
reset(f2);
for i:=1 to N do
readln(f2,b[i]);
read(sl);
for i:=1 to N do
if a[i]=sl then writeln(b[i]);
close(f1);
close(f2)
end.

 

 

Задача принимает до 1000 слов. Чтобы увеличить лимит, поменяй N

Вопросы, недочеты в ЛС

Ответить

Другие вопросы из категории

Видеоадаптер это:

устройство управляющее работой графического дисплея
программа, распределяющая ресурсы видеопамяти
электронное, энергозависимое устройство для хранения информации о графич. изображений
дисплейный процессор

информатика сделать в exel

Читайте также

Помогите написать задачу на паскале

================================================================
В одной берляндской школе появился новый ученик Вася, который очень сильно любил химию. К сожалению для учителя химии, Вася принебрегал техникой безопасности и любил смешивать все реагенты подряд. В кабинете химии находится n реагентов. Каждый реагент характеризуется целым числом - своей опасностью. При смешивании реагентов действовали такиме правилами:

смешивать можно только 2 реагента;
при смешивании реагентов, старые реагенты исчезали и появлялся новый реагент, опасность которого равнялась среднему арифметическому старых.

Известно, что Вася собирается смешивать реагенты до тех пор, пока не останется 1 реагент. Помогите учителю химии определить максимально возможную опасность окончательного реагента.

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:



Вы находитесь на странице вопроса "помогите написать задачу в паскале АBC в файле 1.txt находятся английские слова (записаны столбиком) а в файле 2.txt находятся их русский перевод", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.