Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Помогите, задание с Однородными массивами

10-11 класс

Divaaaaa 15 авг. 2016 г., 2:58:19 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Paulakim1999
15 авг. 2016 г., 3:51:59 (7 лет назад)

9.1:
const  n = 10;
var
  c: array[1..n] of integer;
  p, k, i: integer;
begin
  randomize();
  p := 1; 
writeln('Введите целое число от -15 до 15');
  readln(k);
  for i := 1 to n do
  begin
    c[i] := random(30) - 15;
    if c[i] <= k then
      p := p * c[i];
    writeln(c[i]:4);
  end;
  for i := 1 to n do
    write(c[i]:4);
  writeln(#13#10'Произведение элементов массива, не превышающие ', k ,' равно ', p);
end.
-----------------
9.2:

+ 0 -
сабурчик
15 авг. 2016 г., 5:55:48 (7 лет назад)

На паскале?

+ 0 -
Nastia600
15 авг. 2016 г., 8:03:23 (7 лет назад)

да

+ 0 -
Volk2442
15 авг. 2016 г., 8:49:24 (7 лет назад)

Комментарий удален

+ 0 -
Настёночка21
15 авг. 2016 г., 10:02:09 (7 лет назад)

И если что, массивы бывают одномерными, а не однородными :)

Ответить

Другие вопросы из категории

1) В целочисленном массиве М размера 9 определить

сумму элементов и номера положительных
элементов.

2)

задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла

содержит единственное целое число N(1<=N<=1000)

Формат выходных данных

выведите ответ к задаче

Читайте также

Помогите решить две задачки (Паскаль)

Задание 1
В одномерном массиве случайных вещественных числе F(17) определить количество положительных элементов и их сумму.

Задание 2
В матрице L(5,5) случайных вещественных чисел определить максимальный элемент выше побочной диагонали, поменять его местами с элементом 2 строки 2 столбца.

Большая просьба расписать задачу подробно , хочу не просто списать решения , а понять его и научиться решать сам , огромное спасибо.

44 балла

Помогите решить две задачки (Паскаль)

Задание 1
Создать одномерный массив А, состоящий из сумм столбцов матрицы В(8,5). Определить в созданном массиве минимальный элемент и его местоположение, а также произведение всех элементов.

Задание 2
В двумерном массиве G(7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице вычислить значение произведения элементов главной диагонали. Заменить значение третьего элемента в первой строке на значение произведения.

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!



Вы находитесь на странице вопроса "Помогите, задание с Однородными массивами", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.