Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить программу на Turbo Pascal: вычислить приблизительное значение числа п , используя представление: п/8= 1/1*3+1/5*7+1/9*11 + ...;

10-11 класс

Lyazzatkosuako 21 янв. 2016 г., 17:52:09 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Voronczova
21 янв. 2016 г., 19:30:09 (8 лет назад)


Program funduk46;
uses crt;
const
  eps=0.00001;
var
  t,sum:real;
  i:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Программа вычисляет приблизительное значение числа п,');
  writeln('используя представление: п/8=1/1*3+1/5*7+1/9*11+...');
  writeln();
  writeln('Вычисление прекратится, когда очередноe слагаемоe станет меньше 0,00001');
  writeln();
  sum:=0;
  i:=1;
  t:=1;
  while t>=eps do
    begin
      t:=1/((i)*(i+2));
      sum:=sum+t;
      i:=i+4;
    end;
  sum:=sum*8;
  writeln('Полученный результат: ',sum:14:12);
  writeln('             Число п: ',pi:14:12);
  writeln('Приближение к п равно ',abs(sum-pi):14:12);
end.

Ответить

Читайте также

Написать программу на turbo pascal.

1.Вычислить значение факториала n! (P=1*2*...*n*N)..N=12
2.Найти сумму элементов заданного массива C[1..n]. Данные для ввода: n=7; C[1;2;3;-4;5;-6;7].
3.

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали



Вы находитесь на странице вопроса "Составить программу на Turbo Pascal: вычислить приблизительное значение числа п , используя представление: п/8= 1/1*3+1/5*7+1/9*11 + ...;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.