Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

ПОМОГИТЕ, ПОЖАЛУЙСТА! Написать программу, которая получает возраст человека от 0 до 120 лет и выводит со словом "год", "года", "лет".

10-11 класс

алинка12344748 11 дек. 2014 г., 14:02:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sloupok7
11 дек. 2014 г., 16:23:51 (9 лет назад)

Ищем закономерности.

Год: 1, 21, 31, 41, 51, 61, 71, 81, 91, 101
(оканчивается на единицу, исключение: 11 и 111)
Года: 2-4, 22-24, 32-34, 42-44, 52-54, 62-64, 72-74, 82-84, 92-94, 102-104
(оканчивается на 2, 3 или 4, исключения: 12, 13, 14, 112, 113, 114)
Лет: 0, 5-20, 25-30, 35-40, 45-50, 55-60, 65-70, 75-80, 85-90, 95-100, 105-120
(оканчивается на 0, 5-9, плюс исключения из прошлых пунктов)
У исключений есть общее: остаток при делении на 100 будет в промежутке от 11 до 14.

n - возраст
Язык программирования: Паскаль

var
n : integer ;
begin
read (n) ;
n := n mod 100 ;
if n in [11..14] then
writeln ('лет');
else
begin
n := n mod 10 ;
case n of
1 : writeln ('год') ;
2..4 : writeln ('года') ;
0, 5..9 : writeln ('лет') ;
end ;
readln ;
end.

+ 0 -
03 окт. 2021 г., 20:42:21 (2 года назад)

на с++ можно хоть один ответ все сайты обощёл удже

Ответить

Другие вопросы из категории

слово презентация с латинского
1. Проводится 2 лотереи 4 из 32 и 5 из 64. В какой лотерее выгодней участвовать? 2.Сколько бит информации несет сообщение о том, что из колоды в

32 карты достали даму пик?

3.Придумать пример системы выделить составные части, структуру и системный эффект.

Пожалуйста помогите, Оочень надо. Заранее спасибо :)

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.

Написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами.
Ввод: Число N и элементы массива вводятся из Файла.
Вывод: В файл должны быть введены 2 вычисленных значения

Помогите, пожалуйста! Мне надо подробное решение.

На вход программе подается
последовательность символов, заканчивающаяся точкой. Требуется написать
программу, которая определяет, есть ли в этой последовательности десятичные
цифры, и выводит наибольшее число, которое можно составить из этих цифр.
Ведущих нулей в числе быть не должно (за исключением числа 0, запись которого
содержит ровно одну цифру). Если цифр нет, программа должна вывести на экран
слово «Нет», а если есть – слово «Да» и в следующей строчке искомое число.
Например, если исходная последовательность была такая:

Day 10, mice 8: "Year" 7 is a mistake 91.



Вы находитесь на странице вопроса "ПОМОГИТЕ, ПОЖАЛУЙСТА! Написать программу, которая получает возраст человека от 0 до 120 лет и выводит со словом "год", "года", "лет".", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.