Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Вопрос номер 6. Плииз))

5-9 класс

Indigoss 24 апр. 2015 г., 2:51:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mishaallenov421
24 апр. 2015 г., 4:22:06 (9 лет назад)

var a,b,c,d,x1,x2 : real;
begin
writeln('Введите: a,b,c');
read(a,b,c);
d:=b*b-4*a*c;
if (d > 0) then
begin
x1:=(-b-sqrt(d))/(2*a);
x2:=(-b+sqrt(d))/(2*a);
write ('x1=',x1,' x2=',x2);
end else
if (d = 0) then
begin
x1:=-b/2*a;
write('x1=',x1);
end else
write('Корней нет.');
end.

+ 0 -
Sofasofka03
24 апр. 2015 г., 5:31:01 (9 лет назад)

Program KVUR;
Var A, B, C, D, X1, X2 : Real;
begin
  writeln ('Введите коэффициенты уравнения A, B, C ');
  write ('A = ');  readln(a);
  write ('B = ');  readln(b);
  write ('C = ');  readln(c);
  if A=0 then
    if B=0 then
      if C=0 then writeln('X - любое число')
        else writeln('Корней нет! ')
      else
        begin
          X1:=-C/B;
          writeln('X=',X1);
        end
    else
      begin
        D:=B*B-4*A*C;
        if D<0 then writeln ('Корней нет!')
          else
            begin
              X1:=(-B+sqrt(D))/2/A;
              X2:=(-B-sqrt(D))/2/A;
              writeln ('X1=', X1, ' X2=',X2);
            end;
      end;
End.

Ответить

Другие вопросы из категории

К вредоносным программам относятся

1. черви
2. змеи
3. вирусы
4. трояны
5. бояны

Помогите пожалуйста!!! Ответьте на вопросы которые можете!!!

1. Какие преимущества обеспечивают табличные информационные модели по сравнению со словесными описаниями? Приведите пример.
2. Любое ли словесное описание можно заменить табличной информационной моделью? Приведите пример.
3. Приведите примеры табличных информационных моделей с которыми вы встречались на уроках в школе.
4. Приведите примеры табличных информационных моделей с которыми вы встречались в повседневной жизни.
5. Каких правил следует придерживаться при составлении таблиц?
6. Информация каких видов размещается в столбцах таблицы?
7. К какому типу относится "Табель успеваемости", расположенная в конце дневника.
8. Приведите примеры таблицы ОС
9. Приведите примеры таблицы ООО
10. В какой жизненной ситуации могут оказаться полезными вычислительные таблицы? Приведите предмет.
11. На что следует обращать внимание при заполнении итоговой строки (столбца)
12. Приведите примеры двух классов, объекты которых находятся в отношении взаимно однозначного соответствия.

Читайте также

Ваш приятель Дима живет в доме, в котором 8 квартир. Вы знаете, в какой именно кв. он живет. Подойдя к дому, вы встретили девочку, которая знает номер кв.

Димы, но после каждого вопроса лишь кивает головой (да или нет). Какое наименьшее количество вопросов нужно задать девочке, чтобы узнать номер кв. Димы?

Коля задумывает натуральное число из отрезка от 1 до N. Петя должен это число отгадать. Он может задавать Коле вопросы, допускающие только ответы "Да" или

"нет". Петя разработал алгоритм, позволяющий за наименьшее число вопросов отгадать число задуманное Колей.
Вопрос:
Сколько вопросов потребуется Пете, чтобы отгадать задуманное Колей число, если оно принадлежит отрезку:
1)от 1 до 32
2)от 1 до 512
3)от 1 до 300
4)от 1 до 1024

В некоторой стране автомобильный номер длиной 5 символов составляют из

заглавных букв (задействовано 30 различных букв) и любых десятичных
цифр в любом порядке.
Каждый такой номер в компьютерной программе записывается минимально
возможным и одинаковым целым количеством байт (при этом используют
посимвольное кодирование и все символы кодируются одинаковым и
минимально возможным количеством бит).
Определите объём памяти, отводимый этой программой для записи
50 номеров.

У исполнителя Делитель две команды, которым присвоены номера:

1. раздели на 2
2. вычти 1
Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 1.
Исполнитель работает только с натуральными числами.
Составьте алгоритм получения из числа 65 числа 4, содержащий не более 5 команд. В ответе запишите только номера команд.
(Например, 12112 – это алгоритм:
раздели на 2
вычти 1
раздели на 2
раздели на 2
вычти 1,
который преобразует число 42 в число 4).
Если таких алгоритмов более одного, то запишите любой из них.

1)У исполнителя УТРОИТЕЛЬ две команды, которым присвоены номера:

1. вычти 1
2. умножь на 3
Первая из них уменьшает число на экране на 1, вторая – увеличивает его в три раза.Запишите порядок команд в программе получения из числа 3 числа 16, содержащей не более 5 команд, указывая лишь номера команд.(Например, программа 21211 это программа,которая преобразует число 1 в 4
умножь на 3
вычти 1
умножь на 3
вычти 1
вычти 1
2)Исполнитель робот ходит по клеткам бесконечной вертикальной клетчатой доски,переходя по одной из команд вверх,вниз,вправо,влево в соседнюю клетку в указанном направлении.
вправо
вверх
влево
влево
вниз
вниз
вправо
вправо
вправо
вниз
влево
Укажите наименьше взможное число команд в программе,переводящей Робота из той же начальной клетки



Вы находитесь на странице вопроса "Вопрос номер 6. Плииз))", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.