Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите пожалуйста с задачкой (решить в паскале) Дано массив А[1..n, 1..m]. Составить программу поиска всех элементов массива А, что меньше чем все

10-11 класс

соседние.
В программе нужно применить те значения, что на фото.

Ladytaimova 21 окт. 2014 г., 0:56:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dimapop83
21 окт. 2014 г., 2:46:31 (9 лет назад)

const
  n=3;
  m=5;
var
  i,j:integer;
  a:array[1..n,1..m]of integer;
begin
for i:=1 to n do
  begin
  for j:=1 to m do
    begin
    a[i,j]:=random(10);
    write(a[i,j]:3);
    end;
  writeln;
  end;
write('Искомые элементы: ');
for i:=1 to n do
  for j:=2 to m-1 do
    if (a[i,j]<a[i,j-1]) and (a[i,j]<a[i,j+1]) then
      write(a[i,j]:3);
end.

+ 0 -
Milashka102
21 окт. 2014 г., 4:26:49 (9 лет назад)

соседние - это в строке? Или в строке и столбце? Или в строке, столбце и по диагонали?

+ 0 -
Cool6
21 окт. 2014 г., 5:09:50 (9 лет назад)

Комментарий удален

+ 0 -
Pavel19999
21 окт. 2014 г., 6:43:26 (9 лет назад)

А для крайних элементов (первый и последний столбец) проверку делаем (у них только один сосед). Распечатать только значение элементов без координат?

+ 0 -
Nasty20031
21 окт. 2014 г., 7:58:37 (9 лет назад)

В тексте у тебя сказано, что ищем меньший, а на листочке для большего выражение записано. Как правильно?

+ 0 -
Китобой123
21 окт. 2014 г., 9:27:17 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Читайте также

помогите пожалуйста!! паскаль

Входными данными являются число k, N и N целых чисел.
В массиве определить индекс k-го наибольшего элемента массива.
Считать, что все элементы разные.
Ограничения:
Считать, что все элементы разные.
N принимает значения от 1 до 20.
k принимает значения от 1 до N.
Формат входных данных:
k, N и N целых чисел
Формат выходных данных:
индекс второго наибольшего элемента массива

Помогите пожалуйста!!!!

Составить программу на Паскале. Ввести 10 целых случайных чисел (в интервале от -10 до 10). Вывести исходный массив. Найти и вывести: 1) минимальный элемент и его индекс; 2) сумму всех элементов массива; 3) количество отрицательных элементов. К каждому элементу массива прибавить 1, вывести получившийся массив. Подсказка: 1)random(10)-10 2) положительные: >0 неположительные: <=0 отрицательные: <0 неотрицательные:>=0

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от –1000 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, который находит и выводит среднее арифметическое всех элементов массива, оканчивающихся цифрой 5. Гарантируется, что хотя бы один такое элемент в массиве есть.

НАРОД ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.

Помогите пожалуйста решить задачки в паскале.

1.В одномерном массиве перенести элемент, стоящий на первом месте в конец массива.
2.вывести на печать номера точек, лежащих в круге радиусом r. Координаты точек заданы массивами (x1,x2,...,x10), (y1,y2,...,y10).
3.В одномерном массиве найти сумму положительных, произведение отрицательных, количество четных элементов.
4.Дан массив, состоящий из 50 элементов, найти предпоследний нечетнный элемент.



Вы находитесь на странице вопроса "Помогите пожалуйста с задачкой (решить в паскале) Дано массив А[1..n, 1..m]. Составить программу поиска всех элементов массива А, что меньше чем все", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.