Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите исправить ошибки. Листинг программа: Program Posledow; Var x, y: real; Begin x:=8 Repet`

10-11 класс

y:=SQR(x-8)/6;

Writeln (x:8:3, y:8:3);

x:=x+6;

Until y+5<0;

End.

витахонтос 31 марта 2014 г., 9:43:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VanyasyhaiVanyaSyhai
31 марта 2014 г., 10:31:08 (10 лет назад)

Program Posledow;
Var x, y: real;
Begin
x:=8;
Repeat y:=SQR(x-8)/6;
Writeln (x,' ',y);
x:=x+6;
Until y+5<0;
End.

---

проверь, пожалуйста, правильность программы по условию, потому что очень большой вывод получается.

Ответить

Другие вопросы из категории

написать программы 1)В одномерном массиве с(1:10) найти количество элементов удовлетвор. условию с от i >q и с от i<l . 2)Найти

минимальный и максимальный элемент массива и его индекс .

Ребята помогите очень надо!

Какой информационный объем изображения 2000 на 3000 точек, содержащего 4 цвета?

Читайте также

Помогите исправить ошибки Задание: составить программу на яз. Паскаль с использованием цикла с неизвестным числом повторений для вычислений значения

функции F(x)=sin(x)+tg(x) на отрезке [А, В] при изменении аргумента в точках хi = А+iН, где Н – шаг. А=1, В=2, Н=0,125.

Листинг программы:

Program Tabulir;

Var x, y: real;

Begin x:=1;

While x≤2 do begin

y:=sin(x)+tg(x);

writeln (x:9:1, y:16:3);

x:=x+0,125;

End.

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

Помогите найти ошибки в программе Program Oshibka;

Var a:b;c:Integer;
Begin
Writeln('Введите число ',a);
Readln('a')
b=5
c:=ab;
Writeln('произведение a и b'равно',S);
Readln(a);
End

Переписать,

исправив ошибки в программе:


Program
A;

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.



Вы находитесь на странице вопроса "Помогите исправить ошибки. Листинг программа: Program Posledow; Var x, y: real; Begin x:=8 Repet`", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.