Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Пожалуйста, пожалуйста помогите! Очень срочно надо! Составить программу, которая запрашивает вес пользователя Р и его рост R в см, а затем, если

10-11 класс

выполнится условие Р меньше или равно R-100, то сообщает "Поздравляю. Ваш вес в норме", в противном случае - "Хорошо бы вам немного похудеть"

Смайл764 17 июня 2014 г., 20:14:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Radserkowels
17 июня 2014 г., 21:43:26 (9 лет назад)

Program weight;
Var
a,b: real;
Begin
writeln('Введите ваш вес P');
readln(a);
writeln('Введите ваш рост R');
readln(b);
if a<=b-100
then writeln('Поздравляю. Ваш вес в норме')
Else writeln('Хорошо бы вам немного похудеть');
End.

 

 

В приложении рабочий файл программы 

Пояснения:

1. Переменным a, b присваивается значение real, так как рост и вес могут быть не целыми числами, а дробными.

2. окончания команд writeln, readln, сортируют этапы решения и ввода по строчкам, вместо вывода всё в одну строку.

3.  После условия  a<=b-100 НЕ ставится точка с запятой, так как это часть одного цикла условия (IF - если). если поставить точку с запятой, то программа будет не верна

 

P.s. Почему-то сервис не возволяет скачать файл программы. В общем скопируйте просто из начала решения тогда 

Ответить

Другие вопросы из категории

1. Дан файл целых чисел. Преобразовать его, удалив

нечетные числа. Порядок следования четных чисел сохранить.Решите пожалуйста !

Помогите сделать!

Составить таблицу истинности логической
функции:




Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Задача на pascal abc,решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает

файл каждая строка которого выглядет так: табельный номер,фио,оклад.

ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

Составьте программу, которая для одномерного массива, содержащего n элементов вычисляет и отображает: 1) сумму элементов массива; 2)произведение чётных

элементов; 3) сумму элементов которые делятся на 3; 4) минимальный и максимальный элемент. (используя procedure или function, но чтоб была рекурсия)ПОЖАЛУЙСТА ПОМОГИТЕ ВОПРОС ЖИЗНИ И СМЕРТИ!!



Вы находитесь на странице вопроса "Пожалуйста, пожалуйста помогите! Очень срочно надо! Составить программу, которая запрашивает вес пользователя Р и его рост R в см, а затем, если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.