Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

10-11 класс

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.

Dasha0013 13 окт. 2014 г., 21:08:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
алина19020
13 окт. 2014 г., 23:49:40 (9 лет назад)

Программа на Паскале, описание переменных сами сделаете.

№ 1.

Begin

 s:= 0;

 while s <177 do

   begin

      write ('введите число - ');

      readln (a);

      if (a >=1) and (a<=5) then s:=s+a

   end;

   writeln ('cумма чисел =', s)

end.

№ 2.

begin

  write ('введите длину круга l= ');

  readln (l);

  d:= l/pi;

  writeln('диаметр круга = ', d);

  r:= l/(2*pi);

  writeln('радиус круга = ', r);

  s:=sqr(l)/(4 * pi);

  writeln ('площадь круга =', s)

end.

№ 3.

begin

  write ('введите число а= ');

  readln(a);

  write ('введите число b= ');

  readln(b);

  if a > b then max:=a else max:=b

  writeln ('наибольшее число = ', max);

  if (max mod 2 = 0) then write (' четное') else write ('не четное')

end.

Ответить

Другие вопросы из категории

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.



Вы находитесь на странице вопроса "№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.