Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите сделать. Среди двухзначных чисел найти те, сумма квадратов цифр которых делится на 13 . Какртинка это пример как надо делать

10-11 класс

Sapa1950 31 июля 2015 г., 14:25:13 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tanyakrasaveza
31 июля 2015 г., 16:01:48 (8 лет назад)

var i,n : longint;

begin
 read (n);
 for i:=10 to 99 do begin
  if (sqr(i mod 10))+(sqr(i div 10)) mod 13 = 0 then write (i,' ') else continue;
 end;
end.

Вроде верно...

Ответить

Другие вопросы из категории

Прошу помогите срочно очень надо

с клавиатуры вводится возраст человека целое число от 1 до 120 . программа должна напечатать этот возраст со словом год, года или нет

1.Перевести данное число из десятичной системы счисления в двоичную, восьмеричную, шестнадцатеричную системы счисления.

2.Перевести данное число в десятичную систему счисления.
3. Сложить числа
4.Выполнить вычитание
5.Выполнить умножение.
Примечание:
В заданиях 3-5 проверять правильность вычислений переводом исходных данных и результатов в десятичную систему счисления. В задании 1д получить пять 5 знаков после запятой в двоичном представлении.

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Помогите пожалуйста решить задачи в турбо Паскале!

1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.



Вы находитесь на странице вопроса "Помогите сделать. Среди двухзначных чисел найти те, сумма квадратов цифр которых делится на 13 . Какртинка это пример как надо делать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.