Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите написать программу на паскаль и блок схему

10-11 класс

Найти сумму
1,1-1,2+1,3.......1.n
n- целое, вводится с клавиатуры

Манахова81 18 июля 2013 г., 21:30:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lera17031
18 июля 2013 г., 23:59:55 (10 лет назад)

var
  i,j,s,n:integer;
begin
  write('Задайте значение n: ');
  readln(n);
  s:=1;
  j:=-1;
  for i:=1 to n do
    begin
    s:=s+i+j;
    j:=-j
    end;
  writeln('s=',s);
end.

Тестовое решение:

Задайте значение n: 5
s=15


+ 0 -
Наташуничка
19 июля 2013 г., 1:31:25 (10 лет назад)

Комментарий удален

+ 0 -
Айгерим22
19 июля 2013 г., 2:03:37 (10 лет назад)

члены до н-ого числа

+ 0 -
Arusyak11
19 июля 2013 г., 3:21:47 (10 лет назад)

такие же

+ 0 -
89287597220
19 июля 2013 г., 4:25:00 (10 лет назад)

1.1-1.2+1.3-1.4 и т.д

Ответить

Читайте также

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.



Вы находитесь на странице вопроса "Помогите написать программу на паскаль и блок схему", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.