сделать программу по задаче
10-11 класс
|
В квадратной матрице целых чисел, размерностью N*N, на главной диагонали обнулить все элементы, расположенные после максимального.


var
a:array [1..100,1..100] of longint;
i,j,k,n,g,m:longint;
begin
readln(n);
for i:=1 to n do
for j:=1 to n do
read(a[i,j]);
k:=a[1,1]; g:=1; m:=1;
for i:=1 to n do
if a[i,i]>k then begin k:=a[i,i]; g:=i; m:=i; end;
for i:=g to n do
a[i,i]:=0;
for i:=1 to n do
for j:=1 to n do
begin
write(a[i,j],' ');
writeln;
end;
end.
как-то так, на компиляторе не проверял
Другие вопросы из категории
масиві;інші елементи масива А не змінювати.
Читайте также
Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:
2. Дано натуральное n. Вычислить n!; среднее арифметическое чисел от 1 до n; и среднее геометрическое от 1 до n.
3. Вводится натуральное число a. Вывести среди следующих чисел: 1;1+1/2;1+1/2+1/3;1+.......Найти среди этих чисел первое больше введёного a.
C и, если существует, то какой он (равнобедренный, равносторонний, произвольный).
Заранее большое спасибо!